7 Replies Latest reply: Sep 30, 2013 5:49 PM by Hussein Sawwan-Oracle RSS

    autoconfig failed

    user3715462

      HI All,

       

      ebs 12.1.3

      rac 11gr2 2 nodes

       

      Question: where it get value  # 1 and # 2 values below from

       

       

      SQLPLUS Executable : /u01/oracle/TEST/apps/tech_st/10.1.2/bin/sqlplus

       

       

      SQL*Plus: Release 10.1.0.5.0 - Production on Sat Sep 28 09:43:21 2013

       

      Copyright (c) 1982, 2005, Oracle.  All rights reserved.

       

      Enter value for 1: Enter value for 2: Enter value for 3: ERROR:

      ORA-12502: TNS:listener received no CONNECT_DATA from client

       

       

      Error encountered while running /u01/oracle/TEST/inst/apps/TEST1_test2/admin/install/amscmprf.sql

      ERRORCODE = 1 ERRORCODE_END

      .end std out.

       

      even when it failed. the log file shown "the procedure completed successfully and committed"

      and when open log file for the sql that caused error in this case amscmprf.sql  ( the log file always said the procedure completed successfully and committed)

       

      Can you please give me an advice?

      Thanks in advance.

        • 1. Re: autoconfig failed
          Hussein Sawwan-Oracle

          What is the error code you get at the end of AutoConfig session? If it is 0 and it says AutoConfig completed successfully then you should be good.

           

          Thanks,

          Hussein

          • 2. Re: autoconfig failed
            user3715462

            Thanks  Hussein,

             

            autoconfig  completed with error

            "AutoConfig is exiting with status 3"

             

             

            and also this error.

            Enter value for 1: Enter value for 2: Enter value for 3: ERROR:

            ORA-12502: TNS:listener received no CONNECT_DATA from client

             

             

            i can tnsping , connect from sqlplus  ,ping the hostname. and verified the tnsnames.ora on application tier and do not see anything out of place, but always receive this error

            i just wonder, is it a network/firewall or OS issues.

            the connection is acting sporadic...

            Please advise

            Regards,

            • 3. Re: autoconfig failed
              Hussein Sawwan-Oracle

              Are there any errors in $INST_TOP/admin/log/amscmprf.txt file?

               

              This is most likely something to do with your tnsnames.ora file, so do you have proper entries especially your database is RAC?

               

              Thanks,

              Hussein

              • 4. Re: autoconfig failed
                user3715462

                Thanks Hussein,

                 

                autoconfig failed  below but when i check log file they were all completed successful.

                 

                can you please advise.

                Regards,

                 

                 

                 

                  amswebprf.sql      INSTE8_PRF    1
                cseadmprf.sql      INSTE8_PRF    1

                 

                Directory: /u01/oracle/TEST/inst/apps/TEST_test-1/admin/install
                afadmprf.sh        INSTE8_PRF    1
                afcpctx.sh         INSTE8_PRF   

                1

                 

                SQLPLUS Executable : /u01/oracle/TEST/apps/tech_st/10.1.2/bin/sqlplus

                 

                 

                SQL*Plus: Release 10.1.0.5.0 - Production on Sat Sep 28 11:56:36 2013

                 

                Copyright (c) 1982, 2005, Oracle.  All rights reserved.

                 

                Enter value for 1: Enter value for 2: Enter value for 3: ERROR:

                ORA-12502: TNS:listener received no CONNECT_DATA from client

                 

                 

                Error encountered while running /u01/oracle/TEST/inst/apps/TEST_test-1/admin/install/amswebprf.sql

                • 5. Re: autoconfig failed
                  Hussein Sawwan-Oracle

                  Please search AutoConfig log file for those 4 files/scripts and you should find more details about the error.

                   

                  Please also post the contents of tnsnames.ora file (from the application tier node) here (if possible).

                   

                  Thanks,

                  Hussein

                  • 6. Re: autoconfig failed
                    user3715462

                    Thanks Hussein,

                    i opened an SR with Oracle and after upload the sqlnet trace from application tier, they stated that this was an net service issue

                     

                     

                    ORA-12502: TNS:listener received no CONNECT_DATA from client

                     

                    If you recieve TNS -12502 on a RAC setup, then follow NOTE 453293.1 to check your remote and local listener setup.

                    i then disabled scan listener and local LISTENER and only use EBS listener and it works.

                    Thanks for your helps

                    • 7. Re: autoconfig failed
                      Hussein Sawwan-Oracle

                      user3715462 wrote:

                       

                      Thanks Hussein,

                      i opened an SR with Oracle and after upload the sqlnet trace from application tier, they stated that this was an net service issue

                       

                       

                      ORA-12502: TNS:listener received no CONNECT_DATA from client

                       

                      If you recieve TNS -12502 on a RAC setup, then follow NOTE 453293.1 to check your remote and local listener setup.

                      i then disabled scan listener and local LISTENER and only use EBS listener and it works.

                      Thanks for your helps

                       

                      Thanks for the update.

                       

                      Regards,

                      Hussein