14 Replies Latest reply: Oct 4, 2013 11:28 PM by GTS (DBA) RSS

    installed oel 5.5 but  wrongly updating public-yum-ol6.repo

    GTS (DBA)

      Hello Everyone;

       

      Just now i have installed oel 5.5  but  i have used yum tool with ol6.

      can i stop this or continue ?  please advise me on this. Further , what can i do ?

      i want to install 10g r2 oracle s/w.


       

      # cd /etc/yum.repos.d

      [root@oracle yum.repos.d]# wget http://public-yum.oracle.com/public-yum-ol6.repo

      --2013-10-05 01:26:17--  http://public-yum.oracle.com/public-yum-ol6.repo

      Resolving public-yum.oracle.com... 124.124.252.19, 124.124.252.16

      Connecting to public-yum.oracle.com|124.124.252.19|:80... connected.

      HTTP request sent, awaiting response... 200 OK

      Length: 2778 (2.7K) [text/plain]

      Saving to: `public-yum-ol6.repo'

      100%[==============================================>] 2,778       --.-K/s   in 0s     

      2013-10-05 01:26:26 (35.4 MB/s) - `public-yum-ol6.repo' saved [2778/2778]

       

      [root@oracle yum.repos.d]# yum repolist

      Loaded plugins: security

      ol6_UEK_latest                                                   | 1.2 kB     00:00    

      ol6_UEK_latest/primary                                           | 9.9 MB     03:21    

      ol6_UEK_latest: [#################################                               ] 119/225

      ol6_UEK_latest: [#######################################                         ] 139/225

      ol6_UEK_latest: [########################################                        ] 142/225

      ol6_UEK_latest: [###############################################                 ] 168/225

      ol6_UEK_latest: [#################################################               ] 173/225

      ol6_UEK_latest: [###################################################             ] 180/225

      ol6_UEK_latest                                                                     225/225

      ol6_latest                                                          | 1.4 kB     00:00    

      ol6_latest/primary                                                  |  28 MB     04:25    

      ol6_latest: [######################                                           ] 6294/17870

      ....

       

      Thanks in advance ..

        • 1. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
          User12611628-Oracle

          If all you have done is downloaded the wrong repo file (public-yum-ol6.repo), you should be able to recover by deleting the Version 6 repo file from /etc/yum.repos.d/ directory, cleaning up the yum cache ('yum clean all' command) and then downloading the repo file for Version 5. Hope it helps!

          • 2. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
            GTS (DBA)

            hi user12611628

             

            Thanks for reply. Sorry i did not clean repo 6 already i have started to download  following 'public-yum-el5.repo'

            i i have two different versions repo in my os - does it cause for any problem ?


             

            [root@oracle ~]# cd /etc/yum.repos.d

            [root@oracle yum.repos.d]# wget http://public-yum.oracle.com/public-yum-el5.repo

            --2013-10-05 02:01:20--  http://public-yum.oracle.com/public-yum-el5.repo

            Resolving public-yum.oracle.com... 124.124.252.16, 124.124.252.19

            Connecting to public-yum.oracle.com|124.124.252.16|:80... connected.

            HTTP request sent, awaiting response... 200 OK

            Length: 4067 (4.0K) [text/plain]

            Saving to: `public-yum-el5.repo'

             

            100%[======================================>] 4,067       --.-K/s   in 0s     

            2013-10-05 02:01:23 (39.2 MB/s) - `public-yum-el5.repo' saved [4067/4067]

             

            [root@oracle yum.repos.d]# yum repolist t

            Loaded plugins: security

            el5_latest                                               | 1.4 kB     00:00    

            el5_latest/primary                                       |  14 MB     02:12    

            el5_latest: [###############                                       ] 2911/10121

            el5_latest: [################                                      ] 3022/10121

            el5_latest: [################                                      ] 3031/10121

            el5_latest: [################                                      ] 3050/10121

            el5_latest: [################                                      ] 3051/10121

            el5_latest: [################                                      ] 3089/10121

            el5_latest: [################                                      ] 3115/10121

            el5_latest: [#################                                     ] 3226/10121

            el5_latest: [#####################################                 ] 3821/10121

            el5_latest: [#####################################                 ] 3856/10121

            el5_latest: [########################################                                                      ] 4185/10121

            el5_latest: [##########################################                                                    ] 4344/10121

            el5_latest: [##########################################                                                    ] 4353/10121

            el5_latest: [##########################################                                                    ] 4354/10121

            el5_latest: [################################################                                              ] 4935/10121

            el5_latest: [###################################################                                           ] 5257/10121

            el5_latest: [###################################################                                           ] 5258/10121

            el5_latest: [####################################################                                          ] 5416/10121

            ...

            ...

             

            IT takes long time to download .  manually i have to hit enter key  end of the line ,

            (5258/10121 ),   - > Enter key

            (5416/10121) --> Enter key.

               ..

             

            please provide claer solution about this.

            • 3. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
              User12611628-Oracle

              What is the output of  'ls -l /etc/yum.repos.d' command? Like I said earlier, remove the Version 6 file - /etc/yum.repos.d/public-yum-ol6.repo if you have one on your system, then run the 'yum clean all' command. After that check the output of 'yum repolist' command to make sure it lists only Version 5 repo.

              • 4. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
                GTS (DBA)

                [root@oracle ~]# ls -l /etc/yum.repos.d

                total 8

                -rw-r--r-- 1 root root 4067 Jul 19 22:58 public-yum-el5.repo

                -rw-r--r-- 1 root root 2778 Jul 19 22:58 public-yum-ol6.repo

                 

                # yum repolist t

                Loaded plugins: security

                el5_latest                                               | 1.4 kB     00:00    

                el5_latest/primary                                       |  14 MB     02:12    

                el5_latest: [###############                                       ] 2911/10121

                el5_latest: [################                                      ] 3022/10121

                el5_latest: [################                                      ] 3031/10121

                el5_latest: [################                                      ] 3050/10121

                el5_latest: [################                                      ] 3051/10121

                el5_latest: [################                                      ] 3089/10121

                el5_latest: [################                                      ] 3115/10121

                el5_latest: [#################                                     ] 3226/10121

                el5_latest: [#####################################                                                              ] 3821/10121

                el5_latest: [#####################################                                                              ] 3856/10121

                el5_latest: [########################################                                                           ] 4185/10121

                el5_latest: [##########################################                                                         ] 4344/10121

                el5_latest: [##########################################                                                         ] 4353/10121

                el5_latest: [##########################################                                                         ] 4354/10121

                el5_latest: [################################################                                                   ] 4935/10121

                el5_latest: [###################################################                                                ] 5257/10121

                el5_latest: [###################################################                                                ] 5258/10121

                el5_latest: [####################################################                                               ] 5416/10121

                el5_latest: [#########################################################                                          ] 5912/10121

                el5_latest: [############################################################                                       ] 6135/10121

                el5_latest: [################################################################                                   ] 6585/10121

                el5_latest: [#####################################################################                              ] 7083/10121

                el5_latest: [######################################################################                             ] 7218/10121

                el5_latest: [#######################################################################                            ] 7335/10121

                el5_latest                                                                                                       10121/10121

                ol6_UEK_latest                                                                                        | 1.2 kB     00:00    

                ol6_latest                                                                                            | 1.4 kB     00:00    

                ol6_latest: [############################################                                                       ] 7980/17870

                ...

                ...

                 

                << on terminal 2 >>

                 

                # yum clean all

                Loaded plugins: security

                Existing lock /var/run/yum.pid: another copy is running as pid 5592.

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 52:29 ago

                    State  : Uninteruptable, pid: 5592

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 52:31 ago

                    State  : Uninteruptable, pid: 5592

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 52:34 ago

                    State  : Uninteruptable, pid: 5592

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 52:43 ago

                    State  : Running, pid: 5592

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 52:45 ago

                    State  : Uninteruptable, pid: 5592

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 52:48 ago

                    State  : Uninteruptable, pid: 5592

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 52:50 ago

                    State  : Uninteruptable, pid: 5592

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 53:13 ago

                    State  : Uninteruptable, pid: 5592

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 53:15 ago

                    State  : Uninteruptable, pid: 5592

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 53:17 ago

                    State  : Running, pid: 5592

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 53:19 ago

                    State  : Uninteruptable, pid: 5592

                Another app is currently holding the yum lock; waiting for it to exit...

                  The other application is: yum

                    Memory :  18 M RSS ( 28 MB VSZ)

                    Started: Sat Oct  5 02:01:46 2013 - 53:21 ago

                    State  : Running, pid: 5592

                        ...

                         ....

                • 5. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
                  User12611628-Oracle

                  Try this:

                  - kill pid 5592 (kill -9 5592)

                  - rm /etc/yum.repos.d/public-yum-ol6.repo

                  - yum clean all

                  - yum repolist

                  • 6. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
                    GTS (DBA)

                    @ hi ;


                    Thanks for your help.


                    # kill -9 5592

                    bash: kill: (5592) - No such process

                    [root@oracle ~]# rm /etc/yum.repos.d/public-yum-ol6.repo

                    rm: remove regular file `/etc/yum.repos.d/public-yum-ol6.repo'?

                    [root@oracle ~]# yum clean all

                    Loaded plugins: security

                    Cleaning up Everything

                     

                    # yum repolist

                    Loaded plugins: security

                    el5_latest                                               | 1.4 kB     00:00    

                    el5_latest/primary                                       |  14 MB     02:04    

                    el5_latest: [##############                                        ] 3226/10121

                    • 7. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
                      GTS (DBA)

                      # ls -l /etc/yum.repos.d

                      total 8

                      -rw-r--r-- 1 root root 4067 Jul 19 22:58 public-yum-el5.repo

                      -rw-r--r-- 1 root root 2778 Jul 19 22:58 public-yum-ol6.repo

                      [root@oracle ~]#

                       

                      still  this file is here , can i remove this ? ( red marked)

                      • 8. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
                        User12611628-Oracle

                        Yes, you don't need the Version 6 repo file /etc/yum.repos.d/public-yum-ol6.repo  on a Version 5 system.

                        • 9. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
                          GTS (DBA)

                          @ hi

                           

                          [root@oracle etc]# cd yum.repos.d

                          [root@oracle yum.repos.d]# rm public-yum-ol6.repo

                          rm: remove regular file `public-yum-ol6.repo'? y

                          [root@oracle yum.repos.d]# ls -l /etc/yum.repos.d

                          total 4

                          -rw-r--r-- 1 root root 4067 Jul 19 22:58 public-yum-el5.repo

                           

                          # yum repolist

                          Loaded plugins: security

                          el5_latest                                               | 1.4 kB     00:00    

                          el5_latest/primary                                       |  14 MB     02:04    

                          el5_latest                                                                        10121/10121

                          ol6_UEK_latest                                                         | 1.2 kB     00:00    

                          ol6_UEK_latest/primary                                                 | 4.7 MB     00:34    

                          Current download cancelled, interrupt (ctrl-c) again within two seconds to exit.

                          ol6_UEK_latest/primary                                                 | 2.8 MB     00:20    

                          Error: failure: repodata/primary.xml.gz from ol6_UEK_latest: [Errno 256] No more mirrors to try.

                           

                          Even i removed the  'public-yum-ol6.repo'  file  ol6_UEK_latest is updated automatically. - why so ?

                          how can i stop it ?

                          • 10. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
                            User12611628-Oracle

                            Like I said earlier in my instructions:  After removing the file, you need to clean the cache by running 'yum clean all' command before you try the 'yum repolist'. The order of steps which I listed is important. I am suspecting your cache is still not clean and hence its look for ol6 channels.

                            • 11. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
                              Catch-22

                              I wonder if Oracle Linux 5.5 is actually the best option since version 5.9 is available, which should be fully compatible.

                               

                              Anyway, to fix your yum repository issues:

                               

                              su - root

                              cd /etc/yum.repos.d

                              rm -rf *

                              wget http://public-yum.oracle.com/public-yum-el5.repo

                              yum clean all

                              yum makecache

                               

                              Then before installing Oracle 10g, execute the following:

                               

                              yum install oracle-validated

                              passwd oracle

                              ssh -X oracle@localhost

                              xclock

                               


                              • 12. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
                                GTS (DBA)

                                @ Dude ;


                                Thanks a lot but still i am having some error.

                                please have a look  (blue marked), i don't understand why i am getting error ?

                                can u help me little more ??


                                [root@oracle yum.repos.d]# yum repolist

                                Loaded plugins: security

                                repo id                       repo name                                        status

                                el5_latest                    Oracle Linux 5 Latest (i386)                     enabled: 10,121

                                repolist: 10,121

                                [root@oracle yum.repos.d]#  yum install oracle-validated

                                Loaded plugins: security

                                el5_latest                                                               | 1.4 kB     00:00    

                                Setting up Install Process

                                Resolving Dependencies

                                --> Running transaction check

                                ---> Package oracle-validated.i386 0:1.1.0-18.el5 set to be updated

                                --> Processing Dependency: util-linux >= 2.13-0.52.0.1.el5_4.1 for package: oracle-validated

                                --> Processing Dependency: irqbalance >= 2:0.55-16 for package: oracle-validated

                                --> Processing Dependency: kernel-uek >= 2.6.32 for package: oracle-validated

                                --> Processing Dependency: unixODBC for package: oracle-validated

                                --> Processing Dependency: unixODBC-devel for package: oracle-validated

                                --> Processing Dependency: oraclelinux-release for package: oracle-validated

                                --> Processing Dependency: libaio-devel for package: oracle-validated

                                --> Processing Dependency: libXp for package: oracle-validated

                                --> Running transaction check

                                ---> Package irqbalance.i386 2:0.55-17.el5 set to be updated

                                ---> Package kernel-uek.i686 0:2.6.32-400.29.3.el5uek set to be updated

                                --> Processing Dependency: kernel-firmware = 2.6.32-400.29.3.el5uek for package: kernel-uek

                                --> Processing Dependency: device-mapper-multipath >= 0.4.9-23.0.1.el5 for package: kernel-uek

                                --> Processing Dependency: kexec-tools >= 1.102pre-96.1.1.el5_5.2 for package: kernel-uek

                                --> Processing Dependency: mkinitrd >= 5.1.19.6-75.0.5 for package: kernel-uek

                                --> Processing Dependency: ql2xxx-firmware for package: kernel-uek

                                ---> Package libXp.i386 0:1.0.0-8.1.el5 set to be updated

                                ---> Package libaio-devel.i386 0:0.3.106-5 set to be updated

                                ---> Package oraclelinux-release.i386 0:5-9.0.2 set to be updated

                                ---> Package unixODBC.i386 0:2.2.11-10.el5 set to be updated

                                --> Processing Dependency: unixODBC-libs = 2.2.11-10.el5 for package: unixODBC

                                --> Processing Dependency: libodbc.so.1 for package: unixODBC

                                --> Processing Dependency: libodbcinst.so.1 for package: unixODBC

                                ---> Package unixODBC-devel.i386 0:2.2.11-10.el5 set to be updated

                                ---> Package util-linux.i386 0:2.13-0.59.0.2.el5_8 set to be updated

                                --> Running transaction check

                                ---> Package device-mapper-multipath.i386 0:0.4.9-64.0.6.el5 set to be updated

                                --> Processing Dependency: kpartx = 0.4.9-64.0.6.el5 for package: device-mapper-multipath

                                --> Processing Dependency: device-mapper-multipath-libs = 0.4.9-64.0.6.el5 for package: device-mapper-multipath

                                --> Processing Dependency: libmpathpersist.so.0 for package: device-mapper-multipath

                                --> Processing Dependency: libmultipath.so for package: device-mapper-multipath

                                ---> Package kernel-uek-firmware.noarch 0:2.6.32-400.29.3.el5uek set to be updated

                                ---> Package kexec-tools.i386 0:2.0.3-3.0.4.el5 set to be updated

                                --> Processing Dependency: mkinitrd = 5.1.19.6-61.0.1 for package: libbdevid-python

                                ---> Package mkinitrd.i386 0:5.1.19.6-81.0.1.el5_9 set to be updated

                                --> Processing Dependency: nash = 5.1.19.6-81.0.1.el5_9 for package: mkinitrd

                                --> Processing Dependency: e2fsprogs >= 1.39-36 for package: mkinitrd

                                --> Processing Dependency: iscsi-initiator-utils for package: mkinitrd

                                ---> Package ql2xxx-firmware.noarch 0:1.01.01-0.4.el5 set to be updated

                                ---> Package unixODBC-libs.i386 0:2.2.11-10.el5 set to be updated

                                --> Running transaction check

                                ---> Package device-mapper-multipath-libs.i386 0:0.4.9-64.0.6.el5 set to be updated

                                ---> Package e2fsprogs.i386 0:1.39-36.0.1.el5_9 set to be updated

                                --> Processing Dependency: e2fsprogs-libs = 1.39-36.0.1.el5_9 for package: e2fsprogs

                                ---> Package iscsi-initiator-utils.i386 0:6.2.0.872-16.0.1.el5 set to be updated

                                ---> Package kpartx.i386 0:0.4.9-64.0.6.el5 set to be updated

                                ---> Package libbdevid-python.i386 0:5.1.19.6-81.0.1.el5_9 set to be updated

                                ---> Package nash.i386 0:5.1.19.6-81.0.1.el5_9 set to be updated

                                --> Running transaction check

                                --> Processing Dependency: e2fsprogs-libs = 1.39-23.el5 for package: e2fsprogs-devel

                                ---> Package e2fsprogs-libs.i386 0:1.39-36.0.1.el5_9 set to be updated

                                --> Running transaction check

                                ---> Package e2fsprogs-devel.i386 0:1.39-36.0.1.el5_9 set to be updated

                                --> Processing Conflict: kernel-uek conflicts udev < 095-14.27.0.1.el5_7.1

                                --> Restarting Dependency Resolution with new changes.

                                --> Running transaction check

                                ---> Package udev.i386 0:095-14.29.0.2.el5 set to be updated

                                --> Finished Dependency Resolution

                                 

                                Dependencies Resolved

                                 

                                ================================================================================================

                                Package                          Arch       Version                       Repository      Size

                                ================================================================================================

                                Installing:

                                oracle-validated                 i386       1.1.0-18.el5                  el5_latest      19 k

                                Updating:

                                udev                             i386       095-14.29.0.2.el5             el5_latest     2.4 M

                                Installing for dependencies:

                                device-mapper-multipath-libs     i386       0.4.9-64.0.6.el5              el5_latest     197 k

                                iscsi-initiator-utils            i386       6.2.0.872-16.0.1.el5          el5_latest     1.0 M

                                kernel-uek                       i686       2.6.32-400.29.3.el5uek        el5_latest      24 M

                                kernel-uek-firmware              noarch     2.6.32-400.29.3.el5uek        el5_latest     3.8 M

                                libXp                            i386       1.0.0-8.1.el5                 el5_latest      22 k

                                libaio-devel                     i386       0.3.106-5                     el5_latest      12 k

                                oraclelinux-release              i386       5-9.0.2                       el5_latest     2.8 k

                                ql2xxx-firmware                  noarch     1.01.01-0.4.el5               el5_latest     455 k

                                unixODBC                         i386       2.2.11-10.el5                 el5_latest     290 k

                                unixODBC-devel                   i386       2.2.11-10.el5                 el5_latest     738 k

                                unixODBC-libs                    i386       2.2.11-10.el5                 el5_latest     551 k

                                Updating for dependencies:

                                device-mapper-multipath          i386       0.4.9-64.0.6.el5              el5_latest     122 k

                                e2fsprogs                        i386       1.39-36.0.1.el5_9             el5_latest     832 k

                                e2fsprogs-devel                  i386       1.39-36.0.1.el5_9             el5_latest     576 k

                                e2fsprogs-libs                   i386       1.39-36.0.1.el5_9             el5_latest     120 k

                                irqbalance                       i386       2:0.55-17.el5                 el5_latest      21 k

                                kexec-tools                      i386       2.0.3-3.0.4.el5               el5_latest     307 k

                                kpartx                           i386       0.4.9-64.0.6.el5              el5_latest     465 k

                                libbdevid-python                 i386       5.1.19.6-81.0.1.el5_9         el5_latest      69 k

                                mkinitrd                         i386       5.1.19.6-81.0.1.el5_9         el5_latest     488 k

                                nash                             i386       5.1.19.6-81.0.1.el5_9         el5_latest     1.1 M

                                util-linux                       i386       2.13-0.59.0.2.el5_8           el5_latest     1.9 M

                                 

                                Transaction Summary

                                ================================================================================================

                                Install      12 Package(s)

                                Upgrade      12 Package(s)

                                 

                                Total download size: 39 M

                                Is this ok [y/N]: y

                                Downloading Packages:

                                (1/24): oraclelinux-release-5-9.0.2.i386.rpm                             | 2.8 kB     00:00    

                                (2/24): libaio-devel-0.3.106-5.i386.rpm                                  |  12 kB     00:00    

                                (3/24): oracle-validated-1.1.0-18.el5.i386.rpm                           |  19 kB     00:00    

                                (4/24): irqbalance-0.55-17.el5.i386.rpm                                  |  21 kB     00:00    

                                (5/24): libXp-1.0.0-8.1.el5.i386.rpm                                     |  22 kB     00:00    

                                (6/24): libbdevid-python-5.1.19.6-81.0.1.el5_9.i386.rpm                  |  69 kB     00:00    

                                (7/24): e2fsprogs-libs-1.39-36.0.1.el5_9.i386.rpm                        | 120 kB     00:00    

                                (8/24): device-mapper-multipath-0.4.9-64.0.6.el5.i386.rpm                | 122 kB     00:00    

                                (9/24): device-mapper-multipath-libs-0.4.9-64.0.6.el5.i386.rpm           | 197 kB     00:00    

                                (10/24): unixODBC-2.2.11-10.el5.i386.rpm                                 | 290 kB     00:01    

                                (11/24): kexec-tools-2.0.3-3.0.4.el5.i386.rpm                            | 307 kB     00:02    

                                (12/24): ql2xxx-firmware-1.01.01-0.4.el5.noarch.rpm                      | 455 kB     00:02    

                                (13/24): kpartx-0.4.9-64.0.6.el5.i386.rpm                                | 465 kB     00:02    

                                (14/24): mkinitrd-5.1.19.6-81.0.1.el5_9.i386.rpm                         | 488 kB     00:03    

                                (15/24): unixODBC-libs-2.2.11-10.el5.i386.rpm                            | 551 kB     00:02    

                                (16/24): e2fsprogs-devel-1.39-36.0.1.el5_9.i386.rpm                      | 576 kB     00:03    

                                (17/24): unixODBC-devel-2.2.11-10.el5.i386.rpm                           | 738 kB     00:04    

                                (18/24): e2fsprogs-1.39-36.0.1.el5_9.i386.rpm                            | 832 kB     00:04    

                                (19/24): iscsi-initiator-utils-6.2.0.872-16.0.1.el5.i386.rpm             | 1.0 MB     00:04    

                                (20/24): nash-5.1.19.6-81.0.1.el5_9.i386.rpm                             | 1.1 MB     00:10    

                                (21/24): util-linux-2.13-0.59.0.2.el5_8.i386.rpm                         | 1.9 MB     00:11    

                                (22/24): udev-095-14.29.0.2.el5.i386.rpm                                 | 2.4 MB     00:08    

                                (23/24): kernel-uek-firmware-2.6.32-400.29.3.el5uek.noarch.rpm           | 3.8 MB     00:17    

                                (24/24): kernel-uek-2.6.32-400.29.3.el5uek.i686.rpm                      |  24 MB     01:32    

                                ------------------------------------------------------------------------------------------------

                                Total                                                           180 kB/s |  39 MB     03:44    

                                warning: rpmts_HdrFromFdno: Header V3 DSA signature: NOKEY, key ID 1e5e0159

                                el5_latest/gpgkey                                                        | 1.4 kB     00:00    

                                Importing GPG key 0x1E5E0159 "Oracle OSS group (Open Source Software group) <build@oss.oracle.com>" from /etc/pki/rpm-gpg/RPM-GPG-KEY-oracle

                                Is this ok [y/N]:

                                Is this ok [y/N]: y

                                Running rpm_check_debug

                                Running Transaction Test

                                Finished Transaction Test

                                Transaction Test Succeeded

                                Running Transaction

                                  Updating       : e2fsprogs-libs                                                          1/36

                                  Updating       : e2fsprogs                                                               2/36

                                  Updating       : udev                                                                    3/36

                                  Updating       : util-linux                                                              4/36

                                warning: /etc/pam.d/login saved as /etc/pam.d/login.rpmsave

                                  Updating       : kpartx                                                                  5/36

                                  Installing     : unixODBC-libs                                                           6/36

                                  Installing     : unixODBC                                                                7/36

                                  Installing     : libXp                                                                   8/36

                                  Installing     : iscsi-initiator-utils                                                   9/36

                                  Updating       : kexec-tools                                                            10/36

                                  Updating       : irqbalance                                                             11/36

                                  Installing     : device-mapper-multipath-libs                                           12/36

                                  Installing     : oraclelinux-release                                                    13/36

                                  Installing     : unixODBC-devel                                                         14/36

                                  Installing     : kernel-uek-firmware                                                    15/36

                                  Installing     : libaio-devel                                                           16/36

                                  Installing     : ql2xxx-firmware                                                        17/36

                                  Updating       : nash                                                                   18/36

                                  Updating       : e2fsprogs-devel                                                        19/36

                                  Updating       : device-mapper-multipath                                                20/36

                                  Updating       : mkinitrd                                                               21/36

                                  Updating       : libbdevid-python                                                       22/36

                                  Installing     : kernel-uek                                                             23/36

                                cp: cannot stat `/sbin/firmware_helper.static': No such file or directory

                                  Installing     : oracle-validated                                                       24/36

                                  Cleanup        : libbdevid-python                                                       25/36

                                  Cleanup        : e2fsprogs                                                              26/36

                                  Cleanup        : util-linux                                                             27/36

                                  Cleanup        : nash                                                                   28/36

                                  Cleanup        : irqbalance                                                             29/36

                                  Cleanup        : e2fsprogs-libs                                                         30/36

                                  Cleanup        : device-mapper-multipath                                                31/36

                                  Cleanup        : kexec-tools                                                            32/36

                                  Cleanup        : udev                                                                   33/36

                                  Cleanup        : e2fsprogs-devel                                                        34/36

                                  Cleanup        : mkinitrd                                                               35/36

                                  Cleanup        : kpartx                                                                 36/36

                                 

                                Installed:

                                  oracle-validated.i386 0:1.1.0-18.el5                                                         

                                 

                                Dependency Installed:

                                  device-mapper-multipath-libs.i386 0:0.4.9-64.0.6.el5                                         

                                  iscsi-initiator-utils.i386 0:6.2.0.872-16.0.1.el5                                            

                                  kernel-uek.i686 0:2.6.32-400.29.3.el5uek                                                     

                                  kernel-uek-firmware.noarch 0:2.6.32-400.29.3.el5uek                                          

                                  libXp.i386 0:1.0.0-8.1.el5                                                                   

                                  libaio-devel.i386 0:0.3.106-5                                                                

                                  oraclelinux-release.i386 0:5-9.0.2                                                           

                                  ql2xxx-firmware.noarch 0:1.01.01-0.4.el5                                                     

                                  unixODBC.i386 0:2.2.11-10.el5                                                                

                                  unixODBC-devel.i386 0:2.2.11-10.el5                                                          

                                  unixODBC-libs.i386 0:2.2.11-10.el5                                                           

                                 

                                Updated:

                                  udev.i386 0:095-14.29.0.2.el5                                                                

                                Dependency Updated:

                                  device-mapper-multipath.i386 0:0.4.9-64.0.6.el5 e2fsprogs.i386 0:1.39-36.0.1.el5_9          

                                  e2fsprogs-devel.i386 0:1.39-36.0.1.el5_9        e2fsprogs-libs.i386 0:1.39-36.0.1.el5_9     

                                  irqbalance.i386 2:0.55-17.el5                   kexec-tools.i386 0:2.0.3-3.0.4.el5          

                                  kpartx.i386 0:0.4.9-64.0.6.el5                  libbdevid-python.i386 0:5.1.19.6-81.0.1.el5_9

                                  mkinitrd.i386 0:5.1.19.6-81.0.1.el5_9           nash.i386 0:5.1.19.6-81.0.1.el5_9           

                                  util-linux.i386 0:2.13-0.59.0.2.el5_8         

                                 

                                Complete!

                                [root@oracle yum.repos.d]#

                                [root@oracle yum.repos.d]# yum install kernel-headers

                                Loaded plugins: security

                                Setting up Install Process

                                Resolving Dependencies

                                --> Running transaction check

                                ---> Package kernel-headers.i386 0:2.6.18-371.0.0.0.1.el5 set to be updated

                                --> Finished Dependency Resolution

                                 

                                Dependencies Resolved

                                ================================================================================================

                                Package                Arch         Version                           Repository          Size

                                ================================================================================================

                                Updating:

                                kernel-headers         i386         2.6.18-371.0.0.0.1.el5            el5_latest         1.5 M

                                 

                                Transaction Summary

                                ================================================================================================

                                Install       0 Package(s)

                                Upgrade       1 Package(s)

                                 

                                Total download size: 1.5 M

                                Is this ok [y/N]:  y

                                Downloading Packages:

                                http://public-yum.oracle.com/repo/OracleLinux/OL5/latest/i386/getPackage/kernel-headers-2.6.18-371.0.0.0.1.el5.i386.rpm: [Errno 4] IOError: <urlopen error (-3, 'Temporary failure in name resolution')>

                                Trying other mirror.

                                Error Downloading Packages:

                                  kernel-headers-2.6.18-371.0.0.0.1.el5.i386: failure: getPackage/kernel-headers-2.6.18-371.0.0.0.1.el5.i386.rpm from el5_latest: [Errno 256] No more mirrors to try.

                                • 13. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
                                  Catch-22

                                  Unless you have a problem with your DNS or internet connection, simply keep trying. It seems access to Public YUM is sometimes overloaded.

                                  • 14. Re: installed oel 5.5 but  wrongly updating public-yum-ol6.repo
                                    GTS (DBA)

                                    @ Dude

                                     

                                    okay ! i'll start freshly once again.  If any problem i'll start new thread. Please have a look .

                                    Basically i'm n't a linux guy.