This discussion is archived
8 Replies Latest reply: Oct 4, 2013 3:27 PM by 1003403 RSS

Atg-Endeca 10.1.2 errors

977766 Newbie
Currently Being Moderated
Hi,
i have succefully indexed the data and i can see the records in endeca_jspref,but my experience manager was showing the error .,
****Error: Last attempt to publish to the MDEX Engine failed at 03/25/2013 4:53:11 PM****
i created a sample page in experience manager by using one-column-page template and when iam trying to accessing ,it is giving the following errors.,
****Error Mon Mar 25 12:22:22 IST 2013 1364194342667 /atg/endeca/assembler/AssemblerTools A problem occured assembling requested content. Response from the assembler was {contentUri=/pages/browse, @type=ContentInclude, @error=FileNotFound}****
****Error Mon Mar 25 12:22:22 IST 2013 1364194342667 /atg/endeca/assembler/droplet/InvokeAssembler A problem occurred assembling the content for content item /pages/browse. The response received was {contentUri=/pages/browse, @type=ContentInclude, @error=FileNotFound}. Servicing the error open parameter.****
  • 1. Re: Atg-Endeca 10.1.2 errors
    945011 Newbie
    Currently Being Moderated
    Can you please check following :

    * Is d graph up and running - you can check this in workbench's admin console.
    * If yes does the first error/warning for data not being published occurs when you make changes to page level cartridge or when you make change to contentcollection cartridge ?

    Cheers,
    Mayank Batra
  • 2. Re: Atg-Endeca 10.1.2 errors
    Luc1976 Newbie
    Currently Being Moderated
    Have you tried running the promote_content.(sh|bat) script? This is under the control folder of you Endeca App.
  • 3. Re: Atg-Endeca 10.1.2 errors
    1003403 Newbie
    Currently Being Moderated

    The dreaded "Error: Last attempt to publish to the MDEX Engine failed at" error.

     

    In our project, we are using the IFCR export/import node to move content pages from dev->qa->prod and we see this error a bunch.

     

    I don't assume this is something you are doing, however, the main reason why I am posting to this thread is to see if anyone knows where, if anywhere, the application logs the specific error message?  I have searched through the workbench logs to no avail.

     

    To add information for others that may be merging content data and migrating it, here are the few issues we have noticed.
    1) Be aware that each environment keeps it's own sequence of merch rule ID's (each content group entity has an individual ID), and in the case of importing to another environment and modifying the template, there is a potential for ID collision.  If this happens, you will get the publishing error. (Oracle known issue).
    2) If you do not keep consistent dim value ID's (example: autogen per environment), and a template is using a dim value in the location is does not know, you will see this error.
    3) If you are using other cartridge types that pull in dim val data, and the value does not exist in the environment you are publishing, you will see this error.

     

    I hope that I am just overlooking the lack of logging in this case, cause this is a real troublesome issue.

  • 4. Re: Atg-Endeca 10.1.2 errors
    TimK Explorer
    Currently Being Moderated

    If this is related to the dim val ids that are used as triggers being inconsistent across environments, then Oracle has a patch for this (6.4.0 and 6.4.1).  Describe this issue to them in a ticket and they will direct you to it.

     

    We deployed this patch over a month ago and no longer see the dreaded "Error: Last attempt failed!!!!!"

  • 5. Re: Atg-Endeca 10.1.2 errors
    1003403 Newbie
    Currently Being Moderated

    Promote script promotes the authoring content to live.  It should not resolve this issue since the issue is in Authoring.

  • 6. Re: Atg-Endeca 10.1.2 errors
    1003403 Newbie
    Currently Being Moderated

    Ha, I know you!!

     

    What's the patch # Tim?

  • 7. Re: Atg-Endeca 10.1.2 errors
    TimK Explorer
    Currently Being Moderated

    16761103 PUBLISH ACTION FOR EXPERIENCE MANAGER FAILS ON INVALID DVAL IDS (Patch)

  • 8. Re: Atg-Endeca 10.1.2 errors
    1003403 Newbie
    Currently Being Moderated

    Thanks man.  I will be looking for other patches for the remainder of the day!

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points