This discussion is archived
1 2 Previous Next 19 Replies Latest reply: Oct 7, 2013 7:16 AM by GTS (DBA) RSS

10g installation on OEL5.5 ( required package details)

GTS (DBA) Journeyer
Currently Being Moderated

Hello everyone ;

 

I need information about  required  packages for 10g installation .

This is for my self practice only between two virtual machines on same host and not for commercial purpose.

 

Usually i select  following packages only.IS this enough ? or should i add some additional packages ?

 

GNOME Desktop Environment

Editors

Graphical Internet

Text-based Internet

Development Libraries

Development Tools

Legacy Software Development

Server Configuration Tools

Administration Tools

Base

Legacy Software Support

System Tools

X Window System

System Tools

 

If i need any additional packages , please  provide the details.

Thanks in advance ..

  • 1. Re: 10g installation on OEL5.5 ( required package details)
    Dude! Guru
    Currently Being Moderated

    There is no need to customize the OS installation for the purpose of installing Oracle database under Oracle Linux 5. The default "basic Server" selection is sufficient. To trigger the installation of additional prerequisite software and to set the Oracle database specific kernel and account parameters, simply use YUM to install the oracle-validated package as outlined in your previous discussion. When finally installing 10g you need to instruct the installer to ignore the system prerequisite check. There should be some information on the web. If I remember correctly you need to invoke the installer as following: /path/to/runinstaller -ignoreSysPrereqs. The reason is that Enterprise Linux 5, although compatible, is too far ahead and was not known when the 10g installer was designed.

  • 2. Re: 10g installation on OEL5.5 ( required package details)
    GTS (DBA) Journeyer
    Currently Being Moderated

    @ hello dude

     

    Good evening !

    Just i have installed OEL 5.5 once again as per your suggestion.

    Before  installing all  packages(dependencies) can i update all packages using yum.


    Example :


    # yum update <package name>

    # yum update setarch-2*


    or can i directly go with following command .


    # cd /etc/yum.repos.d

    # wget http://public-yum.oracle.com/public-yum-ol5.repo

     

  • 3. Re: 10g installation on OEL5.5 ( required package details)
    Srini Chavali-Oracle Oracle ACE Director
    Currently Being Moderated

    Is there a reason you are using 10gR2 - you should be using 11gR2. Installed the "oracle-validated" RPM - follow the directions at Oracle Public Yum Server

  • 4. Re: 10g installation on OEL5.5 ( required package details)
    Dude! Guru
    Currently Being Moderated

    If you update all packages using the default public-yum-ol5.repo you will update your system to Oracle Linux 5.9.

     

    This should not be a problem beside the massive download. However, if you want to stay on 5.5 you will need to edit the repo file and disable el5_latest and enable ol5_u5_base. Keep in mind however that this will also disable software and security patches, beside Oracle UEK kernel patches, which is a different repository.

     

    Alternatively if you can also create the following repo file to install software using your installation DVD.

     

    /etc/yum.repos.d/dvd.repo


    [Install_DVD_base]

    name=Install DVD

    baseurl=file:///mnt/Server

    gpgcheck=1

    enabled=1

    skip_if_unavailable=True

     

     

    Then mount the DVD:

     

    cd /

    umount /dev/cdrom

    mount -o loop /dev/cdrom /mnt

     

     

    And install oracle-validated:

     

    yum install oracle-validated

  • 5. Re: 10g installation on OEL5.5 ( required package details)
    GTS (DBA) Journeyer
    Currently Being Moderated

    @ Srini_Chavali

     

    Is there a reason you are using 10gR2  ?


    Yes.  only self practice i'm trying to upgrade from 10.0.0.4.0 to 11. 2.0.1.0. that's it.




  • 6. Re: 10g installation on OEL5.5 ( required package details)
    Srini Chavali-Oracle Oracle ACE Director
    Currently Being Moderated

    I assume you mean 10.2.0.4 (as there is no version numbered 10.0.0.4). Do you have access to the 10g software ? You will need the base software (10.2.0.1) and the 10.2.0.4 patch. The base software is no longer available and the patch is only available from My Oracle Support, access to which requires a paid support contract from Oracle.

     

    HTH
    Srini

  • 7. Re: 10g installation on OEL5.5 ( required package details)
    HDeiby Oracle ACE
    Currently Being Moderated

    Oracle 10.2 for OEL 5 32bits

     

    binutils-2.17.50.0.6-2.el5

    compat-libstdc++-33-3.2.3-61

    elfutils-libelf-0.125-3.el5

    elfutils-libelf-devel-0.125

    gcc-4.1.1-52

    gcc-c++-4.1.1-52

    glibc-2.5-12

    glibc-common-2.5-12

    glibc-devel-2.5-12

    glibc-headers-2.5-12

    libaio-0.3.106

    libaio-devel-0.3.106

    libgcc-4.1.1-52

    libstdc++-4.1.1

    libstdc++-devel-4.1.1-52.e15

    make-3.81-1.1

    sysstat-7.0.0

    unixODBC-2.2.11

    unixODBC-devel-2.2.11

     

     

    Oracle 10.2 for OEL 5 64 bits

     

    binutils-2.17.50.0.6-2 (x86_64)

    compat-db-4.2.52-5.1 (x86_64)

    compat-libstdc++-296-2.96-138 (i386)

    compat-libstdc++-33-3.2.3-61(x86_64)

    compat-libstdc++-33-3.2.3-61 (i386)

    control-center-2.16.0-14 (x86_64)

    gcc-4.1.1-52 (x86_64)

    gcc-c++-4.1.1-52 (x86_64)

    glibc-2.5-12 (x86_64)

    glibc-2.5-12 (i686)

    glibc-common-2.5-12 (x86_64)

    glibc-devel-2.5-12 (x86_64)

    glibc-devel-2.5-12 (i386)

    glibc-headers-2.5-12 (x86_64)

    ksh-20060214-1.4 (x86_64)

    libaio-0.3.106-3.2 (x86_64)

    libgcc-4.1.1-52 (i386)

    libgcc-4.1.1-52 (x86_64)

    libgnome-2.16.0-6 (x86_64)

    libgnomeui-2.16.0-5 (x86_64)

    libgomp-4.1.1-52 (x86_64)

    libstdc++-4.1.1-52 (x86_64)

    libstdc++-devel-4.1.1-52 (x86_64)

    libXp-1.0.0-8 (i386)

    make-3.81-1.1 (x86_64)

    sysstat-7.0.0-3 (x86_64)

  • 8. Re: 10g installation on OEL5.5 ( required package details)
    GTS (DBA) Journeyer
    Currently Being Moderated

    @ HDeiby

     

    I am following  10g installation usually oracle base.com


    ORACLE-BASE - Oracle Database 10g Release 2 (10.2.0.1) Installation On Red Hat Enterprise Linux 5 (RHEL5)


    From Oracle Base , tim has given following packages only.

     

    • setarch-2*
    • make-3*
    • glibc-2*
    • libaio-0*
    • compat-libstdc++-33-3*
    • compat-gcc-34-3*
    • compat-gcc-34-c++-3*
    • gcc-4*
    • libXp-1*
    • openmotif-2*
    • compat-db-4*


    Your suggestion is  below all  ..

     

    • binutils-2.17.50.0.6-2.el5
    • compat-libstdc++-33-3.2.3-61
    • elfutils-libelf-0.125-3.el5
    • elfutils-libelf-devel-0.125
    • gcc-4.1.1-52
    • gcc-c++-4.1.1-52
    • glibc-2.5-12
    • glibc-common-2.5-12
    • glibc-devel-2.5-12
    • glibc-headers-2.5-12
    • libaio-0.3.106
    • libaio-devel-0.3.106
    • libgcc-4.1.1-52
    • libstdc++-4.1.1
    • libstdc++-devel-4.1.1-52.e15
    • make-3.81-1.1
    • sysstat-7.0.0
    • unixODBC-2.2.11
    • unixODBC-devel-2.2.11

     

    When comparing both  , i am getting little bit confused  , please clarify .

     

    Thanks ..

  • 9. Re: 10g installation on OEL5.5 ( required package details)
    Dude! Guru
    Currently Being Moderated

    The oracle-validated package is available for Oracle Linux, not RHEL. The oracle-validated packages will trigger the installation of the prerequisite packages and also setup your oracle acount and kernel parameters.

  • 10. Re: 10g installation on OEL5.5 ( required package details)
    GTS (DBA) Journeyer
    Currently Being Moderated

    @ Dude ..

     

    Yes you are right . Still we are following ( 10g installation on rhel5 and oel5)using   this link only.

     

    ORACLE-BASE - Oracle Database 10g Release 2 (10.2.0.1) Installation On Red Hat Enterprise Linux 5 (RHEL5)


    If any specific link is there .. please kindly provide here ..

    i am not unwilling to find Google search . Already i did .. When i surfing google , some times i get non realted links.


    please provide a valid link to follow 10g installtion on OEL (5 or above)


  • 11. Re: 10g installation on OEL5.5 ( required package details)
    EdStevens Guru
    Currently Being Moderated

    8f953842-815b-4d8c-833d-f2a3dd51e602 wrote:

     

    @ Dude ..

     

    Yes you are right . Still we are following ( 10g installation on rhel5 and oel5)using   this link only.

     

    ORACLE-BASE - Oracle Database 10g Release 2 (10.2.0.1) Installation On Red Hat Enterprise Linux 5 (RHEL5)


    If any specific link is there .. please kindly provide here ..

    i am not unwilling to find Google search . Already i did .. When i surfing google , some times i get non realted links.


    please provide a valid link to follow 10g installtion on OEL (5 or above)


    A big part of the challenge facing you is that you will need both the 10.2.0.0.0 base install as well as the 10.2.0.4 patch.  If you don't already have them in hand (from where?) the only way to get them (legally) is via a Service Request on My Oracle Support, which will in turn require an extended support service contract for 10.2.

     

    Tim's demos at oracle-base are pretty good, but assuming you have the software in hand, the only installation guide you should need is the official Installation Guide at docs.oracle.com.  Your assertion that the link to oracle-base is the only resource you are using is pretty troubling. 

  • 12. Re: 10g installation on OEL5.5 ( required package details)
    GTS (DBA) Journeyer
    Currently Being Moderated

    @ HDeiby

     

    I cannot install anyone package on my system

    ---------------------------------------------

     

    [root@oracle Server]# pwd

    /media/Enterprise Linux dvd 20100405/Server


    [root@oracle Server]# rpm -Uvh binutils-2.17.50.0.6-2.el5

    error: open of binutils-2.17.50.0.6-2.el5 failed: No such file or directory


    [root@oracle Server]# rpm -Uvh compat-libstdc++-33-3.2.3-61

    error: open of compat-libstdc++-33-3.2.3-61 failed: No such file or directory


    [root@oracle Server]# rpm -Uvh glibc-2.5-12

    error: open of glibc-2.5-12 failed: No such file or directory


    [root@oracle Server] # rpm -Uvh elfutils-libelf-0.125-3.el5

    error: open of elfutils-libelf-0.125-3.el5 failed: No such file or directory


    ....

    ....

    .......


    [root@oracle Server]# rpm -Uvh make-3.81-1.1

    error: open of make-3.81-1.1 failed: No such file or directory


    [root@oracle Server]# rpm -ivh make-3.81-1.1

    error: open of make-3.81-1.1 failed: No such file or directory


    [root@oracle Server]# rpm -ivh unixODBC-devel-2.2.11

    error: open of unixODBC-devel-2.2.11 failed: No such file or directory


    [root@oracle Server]# rpm -Uvh unixODBC-devel-2.2.11

    error: open of unixODBC-devel-2.2.11 failed: No such file or directory

  • 13. Re: 10g installation on OEL5.5 ( required package details)
    Dude! Guru
    Currently Being Moderated

    You may not want to use the rpm utility to modify or add software unless you really know what you are doing. The up2date and yum utility are the standard software management tools as of Enterprise Linux 5. Unlike rpm, yum and up2date will handle software dependencies and help you to prevent destroying your software integrity. To use the up2date utility you need a subscription. Don't follow obsolete documentation or advice.

  • 14. Re: 10g installation on OEL5.5 ( required package details)
    HDeiby Oracle ACE
    Currently Being Moderated

    Please insert OEL 5 CD in your computer, after that you will find the packages.

     

    Grettings.

1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points