2 Replies Latest reply: Oct 7, 2013 11:27 AM by Dude! RSS

    Internet is not working on Guest OS.

    GTS (DBA)

      Hello  Everyone ;

       

      Two days before internet was working fine then i have configured  static ip using neat command.

      after that internet connection is not working ! 

      someone  said , if we configure static ip , internet cant access in guest os.

       

      Please help me out from this issue.

       

      [root@oracle ~]# ifconfig

      eth0      Link encap:Ethernet  HWaddr 00:0C:29:88:C5:DA 

                inet addr:192.168.1.200  Bcast:192.168.1.255  Mask:255.255.255.0

                inet6 addr: fe80::20c:29ff:fe88:c5da/64 Scope:Link

                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

                RX packets:368 errors:0 dropped:0 overruns:0 frame:0

                TX packets:56 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:1000

                RX bytes:43981 (42.9 KiB)  TX bytes:7334 (7.1 KiB)

                Interrupt:67 Base address:0x2024

       

      lo        Link encap:Local Loopback 

                inet addr:127.0.0.1  Mask:255.0.0.0

                inet6 addr: ::1/128 Scope:Host

                UP LOOPBACK RUNNING  MTU:16436  Metric:1

                RX packets:2083 errors:0 dropped:0 overruns:0 frame:0

                TX packets:2083 errors:0 dropped:0 overruns:0 carrier:0

                collisions:0 txqueuelen:0

                RX bytes:3803104 (3.6 MiB)  TX bytes:3803104 (3.6 MiB)

       

      Guest OS : oel 5.5 on vmware 9

      Host : windows ultimate

      Thanks  in advance ..

        • 1. Re: Internet is not working on Guest OS.
          rukbat

          Moderator Action:

          You post has been moved from the Database Installation forum space,

          to the Oracle Linux forum space.

           

          You definitely do not have a database installation question.

          You have frustrations with your Linus OS that happems to OL 5.x

           

          However, I actually think you need to ask your question in a VMware forum, as that is likely where your computer system is temporarily messed up - in your host configuration.

          • 2. Re: Internet is not working on Guest OS.
            Dude!

            I'm not using VMware anymore and switched to free Oracle VirtualBox, but the concepts are the same. The default virtual machine NAT adapter is only good for connecting to the Internet using DHCP on behalf of the host OS and cannot be used to address the guest OS from outside.

             

             

            You need to configure the bridged network adapter, or a combination of NAT for outgoing and host-only for incoming network traffic. There is plenty of info on the web and the VMware knowledgeable or Google about using the virtual network editor.