This discussion is archived
7 Replies Latest reply: Oct 14, 2013 4:19 AM by Lakshmanan Sv RSS

Unable to connect to Admin Server from second machine using WLST

qvdfhjryhhrlkrekggfffruh Newbie
Currently Being Moderated

Hello,

 

PROBLEM

----------------

Can't get WLST to connect to admin server from 2nd host to register the domain.

 

SETUP

-------------

I have 2 Centos VMs running on Oracle Virtual box in a single laptop. Both the VMs use "Bridged Networking".

 

VM-1 CONFIG

---------------------

cat /etc/hosts

192.168.1.17

dom1 dom1.my mac1

192.168.1.51centos2 mac2

 

VM-1 hosts admin server & one managed server

 

VM-2 CONFIG

---------------------

192.168.1.51mac2
192.168.1.17

centos1 mac1

 

VM-2 hosts just one managed server

 

I can start up admin on VM-1 fine. The node manager is reachable too. Both the VMs are can be pinged from each other. I can also telnet to the admin server's port ( telnet 192.168.1.17 7001) from the second server.

 

My HOST OS is Windows 7. I can ping from windows to both the VM IPs too. The reverse is working fine as well.

 

I've tried both mechanisms of copying the whole domain from machine 1 over to machine2 & also using the pack.sh/unpack.sh combinations to transfer the domains.

 

When I invoke WLST, this is what happens

 

---------------------------------------------------------------------------------------------------------------

./wlst.sh

 

CLASSPATH=/apps/prod/appservers/weblogic/wls_10_3_6/patch_wls1036/profiles/default/sys_manifest_classpath/weblogic_patch.jar:/apps/prod/appservers/weblogic/wls_10_3_6/patch_ocp371/profiles/default/sys_manifest_classpath/weblogic_patch.jar:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25.x86_64/lib/tools.jar:/apps/prod/appservers/weblogic/wls_10_3_6/wlserver_10.3/server/lib/weblogic_sp.jar:/apps/prod/appservers/weblogic/wls_10_3_6/wlserver_10.3/server/lib/weblogic.jar:/apps/prod/appservers/weblogic/wls_10_3_6/modules/features/weblogic.server.modules_10.3.6.0.jar:/apps/prod/appservers/weblogic/wls_10_3_6/wlserver_10.3/server/lib/webservices.jar:/apps/prod/appservers/weblogic/wls_10_3_6/modules/org.apache.ant_1.7.1/lib/ant-all.jar:/apps/prod/appservers/weblogic/wls_10_3_6/modules/net.sf.antcontrib_1.1.0.0_1-0b2/lib/ant-contrib.jar::/apps/prod/appservers/weblogic/wls_10_3_6/utils/config/10.3/config-launch.jar::/apps/prod/appservers/weblogic/wls_10_3_6/wlserver_10.3/common/derby/lib/derbynet.jar:/apps/prod/appservers/weblogic/wls_10_3_6/wlserver_10.3/common/derby/lib/derbyclient.jar:/apps/prod/appservers/weblogic/wls_10_3_6/wlserver_10.3/common/derby/lib/derbytools.jar::

 

Initializing WebLogic Scripting Tool (WLST) ...

 

Welcome to WebLogic Server Administration Scripting Shell

 

Type help() for help on available commands

 

wls:/offline> connect('weblogic','weblogic123','t3://192.168.1.17:7001')

Connecting to t3://192.168.1.17:7001 with userid weblogic ...

Traceback (innermost last):

  File "<console>", line 1, in ?

  File "<iostream>", line 22, in connect

  File "<iostream>", line 648, in raiseWLSTException

WLSTException: Error occured while performing connect : Error connecting to the server : Could not obtain the localhost address. The most likely cause is an error in the network configuration of this machine.

Use dumpStack() to view the full stacktrace

wls:/offline> dumpStack()

This Exception occurred at Fri Oct 11 17:11:07 NZDT 2013.

java.lang.AssertionError: Could not obtain the localhost address. The most likely cause is an error in the network configuration of this machine.

java.lang.AssertionError: Could not obtain the localhost address. The most likely cause is an error in the network configuration of this machine.

wls:/offline>

---------------------------------------------------------------------------------------------------------------

 

Also, I can't invoke weblogic.Admin from the second VM despite setting the environment using "setWLSEnv.sh". i get the error "Error: Could not find or load main class weblogic.Admin".

 

Please could you help me fix this? I've spent 3 days now trying numerous things without much luck :-(

 

Kind Regards

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points