1 Reply Latest reply: Oct 15, 2013 5:21 PM by Gary Graham-Oracle RSS

    No tables or views listed in connection tree


      I've found several posts about this issue, stretching back several years, but none has come to a conclusion.  I've tried both the most recent production version of SQL Developer, as well as the newest Early Adopter version (, and both have this issue.  I'm able to connect to the database, and run queries against it with no issues.  The problem is that I can't see the list of tables / fields in the Connections tree.  When I click on Tables, it hesitates for just a moment and the plus sign disappears, but nothing is listed.  When I click on Synonyms, all of the tables are listed, but I can't expand on them to get field lists.  Does anyone have a fix for this?

        • 1. Re: No tables or views listed in connection tree
          Gary Graham-Oracle

          That behavior hasn't bothered me in quite some time.  Probably the definitive answer (or at least the most comprehensive theory) comes from John McGinnis in this thread: SQL Developer: Not able to view tables


          I am under the impression the 'Out of Band Breaks' issue shouldn't occur with the 4.0 EA's since those are hardwired to use a more current version of the JDBC driver, but perhaps something about your environment still makes you susceptible.  You should always mention your OS, database, JDK versions.


          If all else fails, have you tried doing a clean install?  That is,

          1. Unzip the product into an empty directory

          2. Only start it up after either...

          2a. Removing/renaming the directory structure containing your user settings, or

          2b. Pointing to some other directory structure via an AddVMOption -Dide.user.dir=<writable_path> line in your sqldeveloper.conf file

          3. Start it up without migrating user settings.


          Hope this helps,


          SQL Developer Team