10 Replies Latest reply: Oct 21, 2013 7:16 PM by user10615659 RSS

    Cannot run OBIEE 11g

    Hibai_

      Hi everybody,

       

      I have installed an 11g version of OBIEE in a Red Hat 5 machine. Initially it worked properly, which means that I was able to connect to the Analytics and work with OBIEE as expected. However, some weeks later I started to face problems while trying to make OBIEE running, and actually I haven't been able to rerun it since then.

       

      The source of my problem may be an RPD I uploaded to the Enterprise Manager which seems to be wrong. Since then, I think I was forced to restart OBIEE due to a poor performance of the tool, and wasn't able to make it running anymore. Anyway and whatever the source of the problem is, when I try to run opmn, this is what I get:

       

       

      [root@JustiziaInf bin]# ./opmnctl startall
      opmnctl startall: starting opmn and all managed processes...
      ================================================================================
      opmn id=JustiziaInf.axpebio.local:9501
      Response: 1 of 2 processes started.

      ias-instance id=instance1
      ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
      --------------------------------------------------------------------------------
      ias-component/process-type/process-set:
         coreapplication_obis1/OracleBIServerComponent/coreapplication_obis1/

      Error
      --> Process (index=1,uid=1064189157,pid=32610)
         failed to start a managed process after the maximum retry limit
         Log:
         /home/Oracle/Middleware/instances/instance1/diagnostics/logs/OracleBIServerComponent/coreapplication_obis1/console~coreapplication_obis1~1.log

      [root@JustiziaInf bin]# ./opmnctl status

      Processes in Instance: instance1
      ---------------------------------+--------------------+---------+---------
      ias-component                    | process-type       |     pid | status 
      ---------------------------------+--------------------+---------+---------
      coreapplication_obiccs1          | OracleBIClusterCo~ |   32486 | Alive  
      coreapplication_obisch1          | OracleBIScheduler~ |   32495 | Alive  
      coreapplication_obijh1           | OracleBIJavaHostC~ |   32484 | Alive  
      coreapplication_obips1           | OracleBIPresentat~ |   32485 | Alive  
      coreapplication_obis1            | OracleBIServerCom~ |     N/A | Down 

       

       

        Thus, I can connect to WebLogic Console and Enterprise Manager without problem, I can even see the login page of the Analytics, but cannot get through it (due to the coreapplication_obis1 issue, I guess).

       

      I have found some advices along the web, but none of them worked for me. So I would be very grateful if somebody could help me to solve the issue, as right now I just cannot work with OBIEE.

       

      Thanks in advance,

       

      Hibai.

        • 1. Re: Cannot run OBIEE 11g
          SunilSharma

          upload your old rpd and restart the services and see how it goes.

           

          meanwhile paste the nqserver.log for anymore suggestions

          • 2. Re: Cannot run OBIEE 11g
            srikkanth

            you cannot run rpd of higher version on lower version machines. let us know, what was earlier rpd version or admin version(admin tool , go to help..it gives rpd version and obiee).

            • 3. Re: Cannot run OBIEE 11g
              Hibai_

              Hi,

               

              I have uploaded a previous rpd, and now OBIEE is running properly.

               

              Referring to the nqserver.log, here is the final extract of the file:

               

              [2013-09-18T13:05:06.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004tePctAKq8lnYFLrnJ8A00015y000000] [tid: ad45cc60]  [36007] Loading repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:05:06.000+00:00] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: ] [tid: ad45cc60]  [nQSError: 36010] Server version 318 cannot read the newer version 325 of the repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:05:06.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: ] [tid: ad45cc60] Server start up failed: [nQSError: 36010] Server version 318 cannot read the newer version 325 of the repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:05:15.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004tePdUU2G8lnYFLrnJ8A00017t000000] [tid: b62efc60]  [36007] Loading repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:05:16.000+00:00] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: ] [tid: b62efc60]  [nQSError: 36010] Server version 318 cannot read the newer version 325 of the repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:05:16.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: ] [tid: b62efc60] Server start up failed: [nQSError: 36010] Server version 318 cannot read the newer version 325 of the repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:06:20.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004tePhJdUq8lnYFLrnJ8A00019j000000] [tid: 4ff19c60]  [36007] Loading repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:06:20.000+00:00] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: ] [tid: 4ff19c60]  [nQSError: 36010] Server version 318 cannot read the newer version 325 of the repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:06:20.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: ] [tid: 4ff19c60] Server start up failed: [nQSError: 36010] Server version 318 cannot read the newer version 325 of the repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:06:25.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004tePhacCo8lnYFLrnJ8A0001AX000000] [tid: 4eaf8c60]  [36007] Loading repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:06:25.000+00:00] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: ] [tid: 4eaf8c60]  [nQSError: 36010] Server version 318 cannot read the newer version 325 of the repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:06:25.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: ] [tid: 4eaf8c60] Server start up failed: [nQSError: 36010] Server version 318 cannot read the newer version 325 of the repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:08:30.000+00:00] [OracleBIServerComponent] [NOTIFICATION:1] [] [] [ecid: 004tePoziiz8lnYFLrnJ8A0001Cj000000] [tid: d8f67c60]  [36007] Loading repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:08:30.000+00:00] [OracleBIServerComponent] [ERROR:1] [] [] [ecid: ] [tid: d8f67c60]  [nQSError: 36010] Server version 318 cannot read the newer version 325 of the repository /home/Oracle/Middleware/instances/instance1/bifoundation/OracleBIServerComponent/coreapplication_obis1/repository/REP_BISAMPLE_BI0002.rpd.

               

               

              [2013-09-18T13:08:30.000+

               

              Seems to be an rpd version issue indeed. The old one's version was 318/325, while the new rpd's version is 325. So now the question would be: what must I do to be able to work with my new rpd?

               

              On the other hand, I had problems to upload the rpd from the Enterprise Manager, since I couldn't find them on the folder browser - just like if they were hidden. I find them while searching with the BI Admin Tool, but I'm unable to do the same with the Enterprise Manager. Eventually I downloaded my rpds from Red Hat machine to a Windows folder, and it worked. Is this a normal behaviour?

               

              Thanks a lot to both of you. Regards,

               

              Hibai.

              • 4. Re: Cannot run OBIEE 11g
                SunilSharma

                you need to patch your OBIEE. what version of OBIEE you have 11.1.1.6.0/x?

                • 5. Re: Cannot run OBIEE 11g
                  srikkanth

                  copy your rpd from that location (where rpd is stored in that unix box /repository).

                  Open that in new version obiee client (7.0/7.1) , then save this rpd with different name and deploy in Enterprise manager now and restart the services ...this will work now.

                  • 6. Re: Cannot run OBIEE 11g
                    user10615659

                    There is a way to downgrade your rpd to an older version. It comes as part of standard installation.

                     

                    try  nqgenoldverrpd.exe. using this you can change the version of your rpd to a lower version that can fit your installation.

                     

                    here in this case downgrade from 325 to 318.

                    mark if this helps.

                    • 7. Re: Cannot run OBIEE 11g
                      Hibai_

                      Hi,

                       

                      It seems that OBIEE is running again with the downgrade using nqgenoldverrpd.exe, but I'm having problems with the server so I will confirm it as soon as I have everything working properly.

                       

                      Thanks to all of you. Regards,

                       

                      Hibai.

                      • 8. Re: Cannot run OBIEE 11g
                        Hibai_

                        Hi,

                         

                        nqgenoldverrpd.exe file indeed allowed me to run OBIEE. But on the other hand, I'm now dealing wiht another problem: although I can enter the OBIEE platform, see the main page and open out-of-the-box sample applications, I cannot create new reports, analysis, dashboards or whatever that seem to have interaction with datasources. That's why I think that the rpd issue may be related with my new issue.

                         

                        Any idea about this new problem? If you mates think that this has nothing to do with rpd issue, I will close this thread and open a a new one.

                         

                        Thanks again. Regards,

                         

                        Hibai.

                        • 9. Re: Cannot run OBIEE 11g
                          SunilSharma

                          this is not RPD issue. Its related to your ID is not having right privileges, application roles etc. You can close this and open a new one.

                          • 10. Re: Cannot run OBIEE 11g
                            user10615659

                            Hi

                             

                            I think your initial problem was solved. Now your rpd is working. please mark my answer as correct.

                            For any new issues open new thread.

                             

                            Senthil