This discussion is archived
3 Replies Latest reply: Oct 17, 2013 3:17 PM by cindys RSS

Trouble mounting zpool

6668614c-e2fe-40cc-a539-f736ea381281 Newbie
Currently Being Moderated

Hi All,

 

I'm having trouble importing a zpool

 

everything says ONLINE apart from 2 vdev's

 

c8t1d0 UNAVAIL corrupted data

c8t2d0 UNAVAIL corrupted data

 

The disks are fine, and all the subsystems are fine, those two disks seem to be reporting slightly different sizes than the others, possibly the GTP tables are damaged?

 

what should I do next to try and repair the pool?

  • 1. Re: Trouble mounting zpool
    cindys Pro
    Currently Being Moderated

    Hi--

     

    Can you see these disks with the format utility? If so, you might try relabeling them if the labels disappeared.

     

    What steps lead up to this problem? Is this a non-redundant pool? If so, the corrupted data is a serious problem.

     

    You can try the zpool import -FXn option but I think the -F option would have been presented when you attempted

    to import this pool. The -FXn will tell you how far back the pool TXG can be restored.

     

    Thanks, Cindy

  • 2. Re: Trouble mounting zpool
    6668614c-e2fe-40cc-a539-f736ea381281 Newbie
    Currently Being Moderated

    Hi Cindy,

     

    Thanks for the reply/help

     

    I can see them in Format, and a I can analyse -> read both disks with no problems, what steps should I take to re-label them?

     

    The issue arose from when I accidently plugged those two disks into a RAID controller, I think the RAID controller wrote some information to the GPT partitions, they both happened to be in the same vdev , they are all the exact same type of disk.

     

    This is the output of :~# zpool import -FXn

     

    pool: titan

        id: 16435494269469739394

    state: UNAVAIL

    status: The pool was last accessed by another system.

    action: The pool cannot be imported due to unavailable devices or data.

       see: http://support.oracle.com/msg/ZFS-8000-EY

    config:

            titan        UNAVAIL  insufficient replicas

              raidz1-0   ONLINE

                c8t3d0   ONLINE

                c8t4d0   ONLINE

                c8t5d0   ONLINE

                c8t6d0   ONLINE

                c8t8d0   ONLINE

              raidz1-1   UNAVAIL  insufficient replicas

                c8t9d0   ONLINE

                c8t10d0  ONLINE

                c8t11d0  ONLINE

                c8t1d0   UNAVAIL  corrupted data

                c8t2d0   UNAVAIL  corrupted data

    device details:

            c8t1d0     UNAVAIL        corrupted data

            status: ZFS detected errors on this device.

                    The device has bad label or disk contents.

            c8t2d0     UNAVAIL        corrupted data

            status: ZFS detected errors on this device.

                    The device has bad label or disk contents.

  • 3. Re: Trouble mounting zpool
    cindys Pro
    Currently Being Moderated

    Hi--

     

    If you have 2 UNAVAIL devices in a RAIDZ1 VDEV, then this is very bad for your data.

    This means that your pool data is no longer consistent.

     

    You might be able to recreate the disk labels for c8t1d0 and c8t2d0 but it is very difficult to do.

    I suggest filing a MOS support ticket to get some possible help.

     

    Thanks, Cindy

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points