This discussion is archived
3 Replies Latest reply: Oct 21, 2013 5:33 AM by EdStevens RSS

Neither Oracle utility nor oracle database  is not  working

Tushar Lapani Newbie
Currently Being Moderated

Hi!!!

I have installed Oracle 11g R2 on Red hat 6.0 as ORACLE user who is owner of all oracle directories ($ORACLE_BASE,$ORACLE_HOME) . It also contains default database ORCL which is created during installation. when i try to connect as follow

$     export ORACLE_SID=ORCL

$     sqlplus / as sysdba

It returns error "command not found"

 

When I try to run other commands such as

1. orapwd

2. lsnrctl

It returns same error of "command not found".

 

So I am stuck here that whats going wrong with database and why i can't access it though oracle has been installed and database created successfully.

Someone help me plz..

  • 1. Re: Neither Oracle utility nor oracle database  is not  working
    Paul M. Oracle ACE
    Currently Being Moderated

    $     export ORACLE_SID=ORCL

    $     sqlplus / as sysdba

    It returns error "command not found"

    Assuming ORACLE_HOME is set, did you set PATH environment variable ? e.g.

    $ export PATH=$ORACLE_HOME/bin:$PATH

  • 2. Re: Neither Oracle utility nor oracle database  is not  working
    rukbat Guru Moderator
    Currently Being Moderated

    Moderator Action:

    Thread moved from the Oracle Linux forum space to the Generic Linux forum space.

     

    Your OS is Redhat Linux.  

    Though OL is built upon RH, it is a different distribution.

    Redhat is not Oracle Linux.

  • 3. Re: Neither Oracle utility nor oracle database  is not  working
    EdStevens Guru
    Currently Being Moderated

    TusharLapani wrote:

     

    Hi!!!

    I have installed Oracle 11g R2 on Red hat 6.0 as ORACLE user who is owner of all oracle directories ($ORACLE_BASE,$ORACLE_HOME) . It also contains default database ORCL which is created during installation. when i try to connect as follow

    $     export ORACLE_SID=ORCL

    $     sqlplus / as sysdba

    It returns error "command not found"

     

    When I try to run other commands such as

    1. orapwd

    2. lsnrctl

    It returns same error of "command not found".

     

    So I am stuck here that whats going wrong with database and why i can't access it though oracle has been installed and database created successfully.

    Someone help me plz..

     

    When you enter a command at the command line, the shell processor needs to know where to find the executable file for that command.  It does this by searching each directory listed in your PATH environment variable.  It if it is unable to locate the the executable in any directory listed in the path, it returns the message you report.

    In addition to setting ORACLE_SID (and ORACLE_HOME) you need to add the ORACLE_HOME/bin directory to your PATH.  The easiest way to make sure your environment variables are correctly set is to use the 'oraenv' utility.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points