This discussion is archived
1 Reply Latest reply: Oct 22, 2013 10:07 AM by user4175474 RSS

Weblogic does not create the tables in the database schema

jmloor Newbie
Currently Being Moderated

Hi

 

I am working in an application usign weblogic 12c (WebLogic Server Version: 12.1.1.0). I have alredy created the database schema (wich is empty) in my postgresql server, registered the driver and created the datasource.

But, when i deploy my application, the tables are not created in the database schema.

This is my persistence.xml:

 

<persistence version="2.0"

  xmlns="http://java.sun.com/xml/ns/persistence" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

  xsi:schemaLocation="http://java.sun.com/xml/ns/persistence http://java.sun.com/xml/ns/persistence/persistence_2_0.xsd">

  <persistence-unit name="pusatix" transaction-type="JTA">

  <provider>org.eclipse.persistence.jpa.PersistenceProvider</provider>

  <jta-data-source>satixDB</jta-data-source>

  <exclude-unlisted-classes>false</exclude-unlisted-classes>

  <properties>

  <property name="toplink.ddl-generation" value="create-tables" />

  <property name="toplink.ddl-generation.output-mode" value="both" />

  <property name="toplink.logging.level" value="FINE" />

  </properties>

  </persistence-unit>

</persistence>

 

I do not see any error when i deploy mi application, or any log entry saying that the attempt of creating the schema failed somehow

 

What can be happening ?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points