1 Reply Latest reply: Oct 23, 2013 1:58 AM by Maran Viswarayar RSS

    How to run ad-hoc RMAN command with Netbackup parameters ?

    9730283

      Oracle version: 11.2.0.3

      OS : Oracle Linux 6.3

       

      All our backups go to tape . We use netbackup. To do backup, we usually run shell scripts scripts whose contents look like below.

       

      run

      {

      ALLOCATE CHANNEL c1 TYPE 'SBT_TAPE';

      SEND 'NB_ORA_CLIENT=flsbr158,NB_ORA_POLICY=flsbr158_rman,NB_ORA_SERV=qualmh238,NB_ORA_SCHED=Daily';

      backup database   FORMAT 'NEHPROD_%d_%U_%t.rbk' tag='NEHPROD_full';

      }

       

      Sometimes we get issues at the Media management layer like below . To debug the issue,  instead of attempting for full database backup or Incremental backup, I want to do a test backup of a small file , like a spfile or control file.

       

      Can I run the SEND command for netbackup parameters without a run block?

       

       

       

      ORA-19506: failed to create sequential file, name="al_5482_1_429479947", parms="

      "

      ORA-27028: skgfqcre: sbtbackup returned error

      ORA-19511: Error received from media manager layer, error text:

         VxBSAValidateFeatureId: Failed with error:

        • 1. Re: How to run ad-hoc RMAN command with Netbackup parameters ?
          Maran Viswarayar

          So are you trying to push the backup to tape via networker from the client ?

           

          Normally Networker connects to DB and then backs up the DB. If you want to use the client to push the backup to the tape, you probably need to invoke the networker agent(nmda) from the command line to call the script to backup to library. Your Oracle User may not have access to the Networker server --> tape library or somehting like that, if you invoke your rman script as Oracle user.

           

          I never tried from the client side in UNIX but i have tried in windows pushing the backups to the tape via networker

           

          Message was edited by: MaranViswarayar My bad-- i thought the backup software was networker, but most probably would be the same for other backup solutions