3 Replies Latest reply: Oct 24, 2013 12:13 AM by a4cc5a34-cb9d-4377-b02c-adce2ff9f9dc RSS

    must disable Windows UAC to use JMC

    a4cc5a34-cb9d-4377-b02c-adce2ff9f9dc

      I recently started trying to use JMC.on windows 7 (32-bit).  I installed java in a directory outside of the protected "Program Files" directory. JMC could not see named pids. Trying to monitor them with JMX or flight recorder resulted in "no connection" warnings of various flavors.  I changed permission on the hsperfdata file, and then JMC showed the pids with names, but still couldn't monitor any of the jvms.  I then totally disabled Windows UAC, and finally I could connect to and monitor jvms.

       

      Is there some particular setup or configuration required for Windows?  I have used JMC on another machine (64-bit) and it worked fine with normal UAC settings.

       

      --jon

        • 1. Re: must disable Windows UAC to use JMC
          Klara Ward, Java Mission Control Dev-Oracle

          Quoting the FAQ: "Make sure that the hsperfdata_<user> directory can be written to. Also make sure that you are using a file system that supports ACLs."

          I'm guessing it's Windows 7, so that should be ok. It might be one of these "have you tried turning it off and on again" issues, reinstalling might do the trick, but hopefully we can make it work anyway.

           

          Does connecting to your jvms with jconsole or jcmd work?

           

          Sounds really strange that JMX connections doesn't work. What kind of no connection warnings did you get?

          • 2. Re: must disable Windows UAC to use JMC
            a4cc5a34-cb9d-4377-b02c-adce2ff9f9dc

            In trying to get things to work I came across the warning about hsperfdata file access, and took care of that (BTW: perhaps the installer should assure this out of the box, especially for Windows, which is such a pain about these kind of things). Jconsole also failed to work.  I did not try jcmd.  Unfortunately I did not save my notes with the error messages. When I get a chance I'll try turning UAC back on and see what happens.

            • 3. Re: must disable Windows UAC to use JMC
              a4cc5a34-cb9d-4377-b02c-adce2ff9f9dc

              I re-enabled UAC and rebooted.  When I ran jmc, this is what I get when I try to connect to a running eclipse process

               

              Could not connect to Eclipse (4356) : Unable to resolve connection URL

              Unable to resolve connection URL

               

              When I try connecting to eclipse via Jconsole I get


              ConnectionFailedSSL1

              ConnectionFailedSSL2


              It offers a button to run "unsecured".  That choice results in the message


              Connection failed.Retry?

              The connection 4356 did not succeed.  Would you like to try again?


              Trying again repeats the same message.


              When I try connecting to Jconsole via JMC, it seems to run OK.  When I try to connect to Jconsole via Jconsole, I get the same error as for eclipse (ConnectionFailedSSL1...).


              I'm turning off UAC again.