This discussion is archived
4 Replies Latest reply: Oct 25, 2013 3:58 PM by David Allan RSS

Getting error while running ua.bat file of Oracle Data Integrator 12cR1 (12.1.2.0.0) version

922274 Newbie
Currently Being Moderated

Hi,

 

I am using windows 7 professional(service pack 1) 64 bit operating system.

After installing the odi 12c (enterprise edition) by executing the odi_121200.jar file I am getting the following error while trying to run the ua.bat file.

 

 

[2013-10-24T16:49:07.861+05:30] [Framework] [INCIDENT_ERROR] [UPGAST-00056] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] error initializing upgrade plug-in for ODI.ODI1

[2013-10-24T16:49:07.861+05:30] [Framework] [INCIDENT_ERROR] [] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] Cause: An unexpected error occurred initializing an upgrade plug-in.

[2013-10-24T16:49:07.861+05:30] [Framework] [INCIDENT_ERROR] [] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] Action: Contact Oracle Support Services.  See the secondary error message for additional details.

[2013-10-24T16:49:07.861+05:30] [Framework] [INCIDENT_ERROR] [] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] [[

java.lang.reflect.InvocationTargetException

  at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

  at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)

  at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)

  at java.lang.reflect.Constructor.newInstance(Constructor.java:526)

  at oracle.ias.update.plugin.Plugin.instantiatePlugin(Plugin.java:248)

  at oracle.ias.update.plugin.Plugin.<init>(Plugin.java:229)

  at oracle.ias.update.plugin.Plugin.getPlugin(Plugin.java:180)

  at oracle.ias.update.plan.PlanStep.getPlugin(PlanStep.java:335)

  at oracle.ias.update.plan.PlanString.<init>(PlanString.java:66)

  at oracle.ias.update.plan.PlanCustom.<init>(PlanCustom.java:74)

  at oracle.ias.update.plan.PlanStep.<init>(PlanStep.java:189)

  at oracle.ias.update.plan.PlanComponent.<init>(PlanComponent.java:203)

  at oracle.ias.update.plan.Template.load(Template.java:161)

  at oracle.ias.update.plan.Template.loadAllTemplates(Template.java:102)

  at oracle.ias.update.UpgradeDriver.loadConfiguration(UpgradeDriver.java:838)

  at oracle.ias.update.UpgradeDriver.main(UpgradeDriver.java:257)

  at oracle.ias.update.UpgradeDriver.main(UpgradeDriver.java:175)

Caused by: java.util.MissingResourceException: Can't find oracle.ias.update.plugin.odi.bundle.ODIResourceBundle bundle

  at java.util.logging.Logger.setupResourceInfo(Logger.java:1518)

  at java.util.logging.Logger.<init>(Logger.java:265)

  at java.util.logging.Logger.<init>(Logger.java:260)

  at oracle.ias.update.UpgradeLogger.<init>(UpgradeLogger.java:60)

  at oracle.ias.update.UpgradeLogger.getLogger(UpgradeLogger.java:93)

  at oracle.ias.update.LoggingManager.create(LoggingManager.java:249)

  at oracle.ias.update.plugin.UpgradePlugin.createPluginLogger(UpgradePlugin.java:195)

  at oracle.ias.update.plugin.UpgradePlugin.<init>(UpgradePlugin.java:181)

  at oracle.ias.update.plugin.odi.ODIPlugin.<init>(ODIPlugin.java:136)

  ... 17 more

 

 

]]

[2013-10-24T16:49:07.869+05:30] [Framework] [ERROR] [UPGAST-00259] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] The getInitialValue method for plug-in ODI.ODI1 will not be called due to a previous error.

[2013-10-24T16:49:07.869+05:30] [Framework] [ERROR] [] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] Cause: An error occurred when loading or initializing the plug-in which prevents the getInitialValue method from executing.

[2013-10-24T16:49:07.869+05:30] [Framework] [ERROR] [] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] Action: Review the log file for additional details.

[2013-10-24T16:49:07.870+05:30] [Framework] [INCIDENT_ERROR] [] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] UPGAST-00251: An error occured reading Upgrade Descriptor file ODI\INSTALLATION\odi12cInstallation_1\odi\plugins\upgrade\odi.xml

[2013-10-24T16:49:07.870+05:30] [Framework] [INCIDENT_ERROR] [] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] The file does not conform to the expected syntax.

[2013-10-24T16:49:07.870+05:30] [Framework] [INCIDENT_ERROR] [] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] See the secondary message for additional information. Contact Oracle Support.

[2013-10-24T16:49:07.871+05:30] [Framework] [INCIDENT_ERROR] [] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] UPGAST-00259: The getInitialValue method for plug-in ODI.ODI1 will not be called due to a previous error.

[2013-10-24T16:49:07.871+05:30] [Framework] [INCIDENT_ERROR] [] [upgrade.Framework] [tid: 1] [ecid: e9250ad8-50dc-45fe-83f5-5c01e7a7dcb4-00000001,0] [[

oracle.ias.update.exception.UpgradeException: UPGAST-00259: The getInitialValue method for plug-in ODI.ODI1 will not be called due to a previous error.

  at oracle.ias.update.plugin.Plugin.getInitialValue(Plugin.java:317)

  at oracle.ias.update.plan.PlanString.<init>(PlanString.java:67)

  at oracle.ias.update.plan.PlanCustom.<init>(PlanCustom.java:74)

  at oracle.ias.update.plan.PlanStep.<init>(PlanStep.java:189)

  at oracle.ias.update.plan.PlanComponent.<init>(PlanComponent.java:203)

  at oracle.ias.update.plan.Template.load(Template.java:161)

  at oracle.ias.update.plan.Template.loadAllTemplates(Template.java:102)

  at oracle.ias.update.UpgradeDriver.loadConfiguration(UpgradeDriver.java:838)

  at oracle.ias.update.UpgradeDriver.main(UpgradeDriver.java:257)

  at oracle.ias.update.UpgradeDriver.main(UpgradeDriver.java:175)

 

 

]]

 

Thanks and Regards

Sunil

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points