0 Replies Latest reply: Oct 25, 2013 9:37 AM by Edson Santos - B2W RSS

    This server does not have deployment for the Web application with context path:

    Edson Santos - B2W

      Hi there, I am facing a weird problem !

       

      I have a cluster environment in an exalogic machine. But my web app only deploys in a single machine (inside cluster) ! It should install in a cluster in both machines, but only one machine holds the App, the other node it seems that not loading the app. Throws me an 500  error.

       

      I got this message :

      <25/10/2013 09h23min52s BRST> <Error> <HTTP Session> <BEA-100057> <This server does not have deployment for the Web application with context path: /MyWebApp. The callback: becomeSecondary failed while replicating the session. Check your configuration; only uniform configurations in a cluster are supported.>

      <25/10/2013 09h23min52s BRST> <Warning> <RMI> <BEA-080003> <RuntimeException thrown by rmi server: weblogic.cluster.replication.ReplicationManager.create(Lweblogic.rmi.spi.HostID;ILweblogic.cluster.replication.ROID;Lweblogic.cluster.replication.Replicatable;)

      weblogic.cluster.replication.ApplicationUnavailableException: WebApp with contextPath: /SacWeb not found in the secondary server.

      weblogic.cluster.replication.ApplicationUnavailableException: WebApp with contextPath: /SacWeb not found in the secondary server

              at weblogic.servlet.internal.session.ReplicatedSessionData.becomeSecondary(ReplicatedSessionData.java:276)

              at weblogic.cluster.replication.WrappedRO.<init>(WrappedRO.java:45)

       

      It´s critical, I m thinking about do again the cluster configuration ! Have you guys any clue ? The cluster configuration is default weblogic.

       

      I am using WebLogic 11g (10.3.6.0)

       

      Have you guys noticed before ?