9 Replies Latest reply on Oct 28, 2013 11:00 AM by 333

    Getting below error when doing base_update.sh


      [10.22.13 17:04:46] INFO: Checking definition from AppConfig.xml against existing EAC provisioning.

      [10.22.13 17:04:48] INFO: Definition has not changed.

      [10.22.13 17:04:48] INFO: Starting baseline update script.

      [10.22.13 17:04:48] INFO: Acquired lock 'update_lock'.

      [10.22.13 17:04:49] INFO: [ITLHost] Starting shell utility 'move_-_to_processing'.

      [10.22.13 17:04:49] INFO: [ITLHost] Starting copy utility 'fetch_config_to_input_for_forge_Forge'.

      [10.22.13 17:04:50] INFO: [ITLHost] Starting backup utility 'backup_log_dir_for_component_ConfigurationGeneratorForge'.

      [10.22.13 17:04:51] INFO: [ITLHost] Starting component 'ConfigurationGeneratorForge'.

      [10.22.13 17:05:21] INFO: [ITLHost] Starting copy utility 'CopyRecsearchConfig'.

      [10.22.13 17:05:21] INFO: [ITLHost] Starting backup utility 'backup_log_dir_for_component_Forge'.

      [10.22.13 17:05:21] INFO: [ITLHost] Starting component 'Forge'.

      [10.22.13 17:05:31] INFO: [ITLHost] Starting backup utility 'backup_log_dir_for_component_Dgidx'.

      [10.22.13 17:05:31] INFO: [ITLHost] Starting component 'Dgidx'.

      [10.22.13 17:05:33] SEVERE: Batch component  'Dgidx' failed. Refer to component logs in /home/atgint/Endeca/endeca/endeca/Apps/CRS/./logs/dgidxs/Dgidx on host ITLHost.

      Occurred while executing line 53 of valid BeanShell script:




      51|        Dgidx.archiveLogDir();


      53|        Dgidx.run();







      [10.22.13 17:05:33] SEVERE: Caught an exception while invoking method 'run' on object 'BaselineUpdate'. Releasing locks.


      Caused by java.lang.reflect.InvocationTargetException

      sun.reflect.NativeMethodAccessorImpl invoke0 - null

      Caused by com.endeca.soleng.eac.toolkit.exception.AppControlException

      com.endeca.soleng.eac.toolkit.script.Script runBeanShellScript - Error executing valid BeanShell script.

      Caused by com.endeca.soleng.eac.toolkit.exception.EacComponentControlException

      com.endeca.soleng.eac.toolkit.component.BatchComponent run - Batch component  'Dgidx' failed. Refer to component logs in /home/atgint/Endeca/endeca/endeca/Apps/CRS/./logs/dgidxs/Dgidx on host ITLHost.


      [10.22.13 17:05:33] INFO: Released lock 'update_lock'.



      FYR - dgidx.log



      === DGIDX: Version = ""

      === Start Time        : Tue Oct 22 17:05:31 2013

      === Arguments         : "/home/atgint/Endeca/endeca/endeca/MDEX/6.4.1/bin/dgidx -v --compoundDimSearch --lang en --out /home/atgint/Endeca/endeca/endeca/Apps/CRS/logs/dgidxs/Dgidx/Dgidx.log --dtddir /home/atgint/Endeca/endeca/endeca/MDEX/6.4.1/conf/dtd --tmpdir /home/atgint/Endeca/endeca/endeca/Apps/CRS/data/temp /home/atgint/Endeca/endeca/endeca/Apps/CRS/data/forge_output/CRS /home/atgint/Endeca/endeca/endeca/Apps/CRS/data/dgidx_output/CRS"

      === Current Directory : /home/atgint/Endeca/endeca/endeca/Apps/CRS

      === Host              : dstindiablrmi42.in.ibm.com

      === Exec Path         : /home/atgint/Endeca/endeca/endeca/MDEX/6.4.1/bin/dgidx

      === Username (uid)    : atgint (509)

      === PID (PPID)        : 7010 (4352)



      Language/collation in use is English (collation=endeca)

      WARN    10/22/13 11:35:31.995 UTC (1382441731995)    DGIDX    {dgidx,baseline}    Lexer/OLT log: level=-1: 2013/10/22 17:05:31 | INFO    | Enabling log callback   

      No application configuration specified. Using "/home/atgint/Endeca/endeca/endeca/Apps/CRS/data/forge_output/CRS" as the application configuration prefix.


      === DGIDX: Starting phase "Read raw dimensions, properties, and records"

      === Current Time    : Tue Oct 22 17:05:32 2013

      === Total Elapsed   : 0.0855 seconds

      === User CPU Time   : 0.0270 seconds

      === System CPU Time : 0.0170 seconds

      === Memory Usage    : 114.54 MB



      Parsing XML dimensions data with validation turned on

      Parsing project file "/home/atgint/Endeca/endeca/endeca/Apps/CRS/data/forge_output/CRS.xml" (project="CRS")

      XMLParser: Reading dimensions, dvals, and synonyms from file "/home/atgint/Endeca/endeca/endeca/Apps/CRS/data/forge_output/CRS.dimensions.xml"

      ERROR    10/22/13 11:35:32.083 UTC (1382441732083)    DGIDX    {dgidx,baseline}    Internal error while decompressing input stream: null   

      FATAL    10/22/13 11:35:32.083 UTC (1382441732083)    DGIDX    {dgidx,baseline}    Fatal error at file , line 0, char 0; Message: An exception occurred! Type:RuntimeException, Message:The primary document entity could not be opened. Id=/home/atgint/Endeca/endeca/endeca/Apps/CRS/data/forge_output/CRS.dimensions.xml   

      WARN    10/22/13 11:35:32.083 UTC (1382441732083)    DGIDX    {dgidx,baseline}    Lexer/OLT log: level=-1: 2013/10/22 17:05:32 | INFO    | Disabling log callback   


      thanks in advance



        • 1. Re: Getting below error when doing base_update.sh
          Gopinath Ramasamy



          Can you check the file permissions on the file /home/atgint/Endeca/endeca/endeca/Apps/CRS/data/forge_output/CRS.dimensions.xml and the containing folder?



          Gopinath Ramasamy

          • 2. Re: Getting below error when doing base_update.sh

            Hi gopi,

            getting below error on running initialize_Service.sh


            [localhost control]$ ./initialize_services.sh

            Exception in thread "main" java.lang.NoClassDefFoundError: com/endeca/soleng/eac/toolkit/Controller

            Caused by: java.lang.ClassNotFoundException: com.endeca.soleng.eac.toolkit.Controller

                    at java.net.URLClassLoader$1.run(URLClassLoader.java:200)

                    at java.security.AccessController.doPrivileged(Native Method)

                    at java.net.URLClassLoader.findClass(URLClassLoader.java:188)

                    at java.lang.ClassLoader.loadClass(ClassLoader.java:303)

                    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

                    at java.lang.ClassLoader.loadClass(ClassLoader.java:248)

                    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:316)

            Could not find the main class: com.endeca.soleng.eac.toolkit.Controller.  Program will exit.

            • 3. Re: Getting below error when doing base_update.sh

              Hi Gopi,

              thanks for the response.

              as you said, i have give the file permission to all the .xml which is reside in forge_output folder , but still am getting the same issue.

              looking for your help

              • 4. Re: Getting below error when doing base_update.sh
                Gopinath Ramasamy



                Can you give me the below details?


                1. Are you doing a fresh installation of Endeca or migration?

                2. What versions of MDEX, Platformservices, ToolsandFrameworks you have?

                3. What are the steps / document you followed for the installation? Mention any deviations from the steps in the document?

                4. Related environment variables and its value



                Gopinath Ramasamy

                • 5. Re: Getting below error when doing base_update.sh

                  Hi Gopi,

                  Again thanks for the response.


                  am doing fresh endeca installation (mdex - 6.4.1, platform 6.1.3, cas 3.1.2, tools 3.1.2)

                  The exact issue when am running baseline_update is :

                  /app/local/endeca/Apps/CRS/data/forge_output/CRS.Dimension.xml is empty (file size is 0),


                  can you suggest me how to rectify this error

                  • 6. Re: Getting below error when doing base_update.sh
                    Gopinath Ramasamy



                    Can you try the below steps?


                    1. Locate the <YOUR_APP_FOLDER>/config/script/DgraphDefaults.xml

                    2. In the <dgraph-defaults> section, add the below arguments.



                    3. Start the initialize_services.sh followed by load_baseline_test_data.sh followed by baseline_update.sh.



                    Gopinath Ramasamy

                    • 7. Re: Getting below error when doing base_update.sh
                      Michael Peel-Oracle

                      Something is going wrong upstream of the Dgidx job, either due to the configuration being incorrect or an issue with the data.  Check the Forge log, ./logs/forges/Forge/Forge.log, as well as the ConfigurationGeneratorForge log, ./logs/forges/ConfigurationGeneratorForge/ConfigurationGeneratorForge.log - see if there are any WARN messages in there that will help you work out the cause.  Note the Forge step reads in the data, the ConfigurationGeneratorForge step is the one that creates the


                      You mention the CRS.Dimension.xml file is empty, did you mean CRS.dimensions.xml?  There should be a file called CRS.dimensions.xml (not CRS.Dimension.xml), and it definitely shouldn't be 0 bytes - it should at least contain an XML declaration as well as a <DIMENSIONS /> node.  If you have a file called CRC.Dimension.xml instead of that, check your ./config/pipeline/pipeline.epx file and the filename in the URL parameter of the DIMENSION_ADAPTER component.  Also check the content of the ./data/forge_output/ directory, there should be a binary file in there that contains the record data.  Check the file size of that, if it is close to zero then something is going wrong during the data ingest stage. 



                      • 8. Re: Getting below error when doing base_update.sh

                        Hi Gopi,

                        thanks for the reply

                        I tried the above steps which you mentioned in the previous post, but still am getting same error.

                        • 9. Re: Getting below error when doing base_update.sh

                          Hi Michael,

                          i checked the log file. which you mentioned , the file name is CRS.dimensions.xml the file size is zero (o), and the binary file is about 17 size.

                          can you suggest me with someother steps to resolve this issue.