This discussion is archived
1 2 Previous Next 15 Replies Latest reply: Nov 6, 2013 4:48 AM by EdStevens RSS

(ORA-12547: TNS:lost contact | ORA-12541: TNS:no listener)Installing Oracle 11gR2 on Ubuntu 12.04 on amazon VM

we*447480*79 Newbie
Currently Being Moderated



I have installed Oracle 11gR2 on Ubuntu 12.04 on amazon VM using following doc.

all components installed successfully but 'Database Configuration Assistant' failed so database also didn't installed successfully.
I have created new database using dbca. database created successfully but keep giving the warning 'ORA: 12547: TNS: lost contact' many times within database installation.

After that i try to connect database but failed.


when i give complete string "sqlplus user/pwd@service"

it give following error

ORA-12541: TNS:no listener


when i connect as "sqlplus /nolog"

it connect to sql prompt

then on sql prompt i do "SQL> conn /as sysdba"

it give following error

ORA-12547: TNS:lost contact


Moreover my service is working but listener is not responding at all.
if i pass any of following command the os didn't return any error or warning or anything and os prompt jump to next line.

lsnrctl status listener_name

lsnrctl start listener_name

lsnrctl stop listener_name


what i have already done by reading the different forums is as under, but it didn't worked.



chmod 6751 oracle

above didn't worked for me.

$ORACLE_HOME/ from root
above didn't worked for me.


cd $ORACLE_HOME/bin relink

above didn't worked for me.

can some one help me out of (ORA-12547: TNS:lost contact | ORA-12541: TNS:no listener)?

I wonder the installation doc i use may missed any package need install on os.


1 2 Previous Next


  • Correct Answers - 10 points
  • Helpful Answers - 5 points