This discussion is archived
1 Reply Latest reply: Nov 4, 2013 1:53 AM by Mooki-Moo RSS

JNLP Works on Linux but not on Windows

Mooki-Moo Newbie
Currently Being Moderated

Hi All,

 

I have various .jnlp files that when executed on Linux (Arch Linux  3.11.4-1 x64) using IcedTea v1.4.1 work as expected, however when used on Windows (Windows 7 x64) either by double clicking or using javaws (v10.45.2.18-fcs) from the CLI fail with a "NoClassDefFoundError". Has anyone came across this before? I'm using 1.7.0_45 in both cases and all jars are digitally signed with a bought Certificate.

 

Can anyone help shed any light on this please, I'd really appreciate it.

 

--

Mooki-Moo

  • 1. Re: JNLP Works on Linux but not on Windows
    Mooki-Moo Newbie
    Currently Being Moderated

    Hello.

     

    Me again. Is anyone able to help me out here, this is driving me to distraction. In addition to the above when using a hand crafted applet tag I get the same "NoClassDefFoundError" error. But I have tried all manner of paths, codebases, added various attributes to my (ant built) manifest file including Application-Name, Application-Library-Allowable-Codebase, Caller-Allowable-Codebase some out of desperation.

     

    I know what the error is telling me but I simply cannot see where I am going wrong. If I write a syntactically correct applet tag or jnlp file I can execute all of these on Linux using various methods but my Windows machine fails consistently with the aforementioned error.  When using a browser the HTML, JNLP and JAR files are all served via HTTPS.

     

    If anyone can help I'd be very greatful.

    --

    Mooki-Moo

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points