0 Replies Latest reply: Nov 4, 2013 9:53 PM by JeMo RSS

    10g XE: ORA-02291, constraint wwv_flows_fk violated while import an application

    JeMo

      Good afternoon Everybody!

       

      Each time when I import an application into my workspace in local 10g XE using the APEX 4.2 Application Builder, I get the "ORA-02291, constraint wwv_flows_fk violated..". The application I whant to import  was originally exported from apex.oracle.com.

       

      I found out, that it has to to with wwv_flow_application_install.get_workspace_id in the installation script, which obviously returns NULL and not my current workspace id as I suppose it should. I replaced wwv_flow_application_install.get_workspace_id by '<my worskspace id>' and then the import does work.

       

      I have this problem neither on non-XEs nor on apex.oracle.com. I seems to be an XE issue.

       

      Have someone an idea, why I have this problem on 10g XE?

       

      Thank You very much!