6 Replies Latest reply: Nov 14, 2013 8:17 AM by jcarrier RSS

    Report keeps getting corrupted

    jcarrier

      Hi,

       

      We had a report in Workspace that was corrupted and gave a NullPointerException error.  This meant we couldn't open it in FR Studio or Workspace, and it fail every time it was run.  The workaround we found was to take a copy of this report from our Dev environment and just re-import it to Production.  This worked for our month end close process, and the report ran successfully.  Until this month where we received the same error and same issue.  We did the same work around and the report worked again.  The biggest issue we're facing is how to even troubleshoot the corrupt report, since we can't open it once it's corrupted.  Any one faced a similar issue or have any idea on how to fix this?

       

      Thank you,

      Jeff

        • 1. Re: Report keeps getting corrupted
          gdeepak

          We faced that issue before, And it was later discovered that when we opened the reports during data load or deployment of the essbase cube (mainly deployment), we got that error. 

           

          So check if some activity is being performed on the source whenever u encounter that error. We shouldnt open the reports during that time.

           

          Our essbase application is stabilized now and we havent deployed it since months and we didnt get that error in reports again.

          • 2. Re: Report keeps getting corrupted
            jcarrier

            We hadn't opened this report until our scheduled batches that included it failed, due to the same NullPointerException.  So I don't think it could have been corrupted in that way. 

            • 3. Re: Report keeps getting corrupted
              gdeepak

              I actually meant, we are not supposed to open the reports and not supposed to run the reports during the time changes are being done on the source.  So, are you sure that no changes were being done on source during the time your batch was running?

               

              Regards

              Deepak

              • 4. Re: Report keeps getting corrupted
                jcarrier

                Yes, this report is part of our standard close process, and doesn't change.  We also run this report overnight at about 2am, so we wouldn't have any users accessing the report while it's running.

                 

                Based on the timeline of events, it seems to be breaking in between being run.  After we got this error the first time and replaced the report, it ran successfully.  Then, when the next month end close process started and we ran the report, it failed consistently again.  We replaced it again and it ran fine.  We're going to rebuild the report from scratch and see if that makes a difference, but we're open to any additional solutions.

                 

                Thank you,

                Jeff

                • 5. Re: Report keeps getting corrupted
                  gdeepak

                  I meant someone accessing the data source ie essbase or HFM or planning during the time reports are run. As you say it is 2am, may be there wont be users accessing the datasouce but, do you have any kind of scripts or data syncs running on data source at the same time?

                   

                  Regards

                  Deepak

                  • 6. Re: Report keeps getting corrupted
                    jcarrier

                    No we schedule our reports around all of our scripts and processes so nothings running at the same time.  Nothing else is running at the same time as this report.

                     

                    Thanks,

                     

                    Jeff