This discussion is archived
3 Replies Latest reply: Nov 19, 2013 9:45 PM by user12876964 RSS

error while installing juicer on oracle linux 6

user12876964 Newbie
Currently Being Moderated

Hi Team,

 

I have juicer installation on my plate, i installed ruby and rubygem as pre-requisite for juicer but while running below command after successful installation i am getting error stating "cannot load such file -- nokogiri/nokogiri".

while i have installed nokogiri already.

 

~# juicer --version

/usr/local/lib/ruby/site_ruby/2.0.0/rubygems/custom_require.rb:36:in `require': cannot load such file -- nokogiri/nokogiri (LoadError)

  from /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/custom_require.rb:36:in `require'

  from /usr/local/lib/ruby/gems/2.0.0/gems/nokogiri-1.5.6/lib/nokogiri.rb:27:in `<top (required)>'

  from /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/custom_require.rb:59:in `require'

  from /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/custom_require.rb:59:in `rescue in require'

  from /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/custom_require.rb:35:in `require'

  from /usr/local/lib/ruby/gems/2.0.0/gems/juicer-1.1.1/lib/juicer/install/base.rb:1:in `<top (required)>'

  from /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/custom_require.rb:55:in `require'

  from /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/custom_require.rb:55:in `require'

  from /usr/local/lib/ruby/gems/2.0.0/gems/juicer-1.1.1/lib/juicer/install/closure_compiler_installer.rb:2:in `<top (required)>'

  from /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/custom_require.rb:55:in `require'

  from /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/custom_require.rb:55:in `require'

  from /usr/local/lib/ruby/gems/2.0.0/gems/juicer-1.1.1/lib/juicer.rb:61:in `block in require_all_libs'

  from /usr/local/lib/ruby/gems/2.0.0/gems/juicer-1.1.1/lib/juicer.rb:61:in `each'

  from /usr/local/lib/ruby/gems/2.0.0/gems/juicer-1.1.1/lib/juicer.rb:61:in `require_all_libs'

  from /usr/local/lib/ruby/gems/2.0.0/gems/juicer-1.1.1/lib/juicer.rb:66:in `<top (required)>'

  from /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/custom_require.rb:55:in `require'

  from /usr/local/lib/ruby/site_ruby/2.0.0/rubygems/custom_require.rb:55:in `require'

  from /usr/local/lib/ruby/gems/2.0.0/gems/juicer-1.1.1/bin/juicer:3:in `<top (required)>'

  from /usr/local/bin/juicer:19:in `load'

  from /usr/local/bin/juicer:19:in `<main>'

 

~]# gem list

 

*** LOCAL GEMS ***

closure-compiler (1.1.10)

cmdparse (2.0.5)

dev-utils (1.0.1)

extensions (0.6.0)

json (1.8.1)

juicer (1.1.1)

mini_portile (0.5.2)

minitest (5.0.8)

nokogiri (1.5.6, 1.5.0)

rake (10.1.0)

rdoc (4.0.1)

rubyzip (0.9.9)

 

I need your urgent help on this as I am totally stuck here. Thanks in advance.

  • 1. Re: error while installing juicer on oracle linux 6
    user12876964 Newbie
    Currently Being Moderated

    I installed same on Redhat linux and didn't face any issue.....so the issue with oracle only. Any help on this??

  • 2. Re: error while installing juicer on oracle linux 6
    Dude! Guru
    Currently Being Moderated

    When asking a question is often helps to explain what the software is good for and how to reproduce the problem. This is not a juicer or ruby forum and there are probably not many if any user familiar with juicer in this forum. But for what it's worth, the following works in Oracle Linux 6.3 x86 and probably other release versions:

     

     

    curl -L https://get.rvm.io | bash -s stable --ruby

    source /usr/local/rvm/scripts/rvm

    ruby --version

    ruby 2.0.0p247 (2013-06-27 revision 41674) [x86_64-linux]

    gem install --verbose juicer

    juicer --version

    juicer 1.1.1

     

    juicer help

    Usage: juicer [global options] COMMAND [options] [ARGS]

     

    Available commands:

        help            Provide help for individual commands

        install         Install a third party library

        list            Lists all dependencies for all input files/patterns

        merge           Combines and minifies CSS and JavaScript files

        verify          Verifies that the given JavaScript/CSS file is problem free

        version         Show the version of the program

     

    Global options:

        -v, --verbose                    Be verbose when outputting info

        -q, --quiet                      Only log warnings and errors

        -h, --help                       Show help

            --version                    Show the version of the program

     

     

    P.S. nokogiri requires Ruby version >= 1.9.2.

  • 3. Re: error while installing juicer on oracle linux 6
    user12876964 Newbie
    Currently Being Moderated

    Thanks for the help Dude!!

    It really helped.

     

    I tried above steps but stuck with loading openssl error, so i recompiled openssl and followed above steps. It works now.

     

    Regards,

    Prasant Rana

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points