0 Replies Latest reply: Nov 18, 2013 10:19 AM by aditya_kar RSS

    ForgeComponent.cleanDirs unable to clear "processing"




      We're using MDEX 6.2.2 with PlatformServices 6.1.2 on a Red Hat Enterprise Linux Server v5.7.


      We've started facing a strange problem lately. While executing a baseline, it fails at Forge.getIncomingData. It fails while trying to move a sub-folder folder from data/incoming to data/processing. On further analysis we realized that the problem is being caused by the Forge.cleanDirs method. This method is meant to clear out the input-dir, output-dir and temp-dir configured for the Forge component. However, in this case, it is unable to clear the contents of the input-dir (data\processing). When this method is called, it simply skips cleaning this directory as if it is already empty.


      We checked the permissions on this folder didn't find any issues. The 'endeca' user is the owner and even with a 777 access, this method is unable to clear it out. However, we are able to clean it manually with the same user.


      We were able to fix this problem temporarily by deleting the 'processing' folder itself and then re-creating it. It worked fine for a couple of days and then the same error resurfaced.


      This problem is present is only on one specific ITL server in our environment.


      Any pointers would be greatly appreciated.




      Warm regards,