1 Reply Latest reply: Nov 20, 2013 12:52 PM by clcarter RSS

    Problem with DBMS_XDB.SETLISTENERLOCALACCESS (error PLS-00201)


      Hello everyone,


      I'm new to oracle and I have a problem after my installation.

      I install Oracle XE 11.2 on CENTOS 6.

      The installation does not seem to be a problem.


      Now I'm trying to activate the web interface for my lan with the command EXEC DBMS_XDB.SETLISTENERLOCALACCESS (FALSE);


      Unfortunately it does not work. Here is the error:


      -bash-4.1$ ./sqlplus / as sysdba

      SQL*Plus: Release Production on Wed Nov 20 15:40:23 2013

      Copyright (c) 1982, 2011, Oracle.  All rights reserved.

      Connected to:

      Oracle Database 11g Express Edition Release - 64bit Production




      ERROR at line 1:

      ORA-06550: line 1, column 7:

      PLS-00201: identifier 'DBMS_XDB.SETLISTENERLOCALACCESS' must be declared

      ORA-06550: line 1, column 7:

      PL/SQL: Statement ignored



      If someone can help me ... (and sorry for my english).

        • 1. Re: Problem with DBMS_XDB.SETLISTENERLOCALACCESS (error PLS-00201)

          Pretty sure the ...setlistenerlocalaccess call is not needed for the 11g XE version, by default in a 10g XE install remote apex access was disabled "out of the box". There was a change to that behavior in the final (?) 11g installer.


          Try a `desc[ribe] dbms_xdb` in sqlplus, that should give a (fairly long) listing of that package, its procedures and functions. What matters for getting the apex web pages working is a few items that relate to the network setup for the host and how the installer gets all that set up in the $ORACLE_HOME/network/admin/listener.ora file.


          Also note per the XE docs, Managing Network Connections says to use a SYSTEM connection, not SYSDBA, although for the XE setup on my (windows host) either a sysdba or a system connection both run that exec statement OK for me. Might be a linux vs. windows thing.


          A `lsnrctl status` output will show an HTTP presentation endpoint (default port 8080) in the section "Listener endpoints ..." as well as an endpoint to service remote database connection requests on port 1521. If the 8080 endpoint is not showing up, nothing will get the apex working. Nothing.


          And if you want to connect to apex from a different (remote) host be sure port 8080 is open in the firewall. That step is a frequent tripping point for lots of folks.


          Message was edited by: clcarter added system connection info from XE docs