3 Replies Latest reply: Nov 20, 2013 5:54 PM by Edward Pang RSS

    Failure of server APACHE bridge:

      We are finishing off an upgrade from forms/reports 6 to 11g, and apart from the normal issues, this has gone very smoothly, but when running some of the 11g reports we are getting the error

      Failure of server APACHE bridge:
      No backend server available for connection: timed out after 10 seconds or idempotent set to OFF or method not idempotent.

      This looks to happen when a running report has not returned the data to the run report window within 5 minutes (happens for both slow queries that fail to return data within that period and also reports where the query is quick, but large numbers of pages are getting produced - some of the reports produce thousands of pages when doing open queries).

      Afraid i am not a DBA or administrator so struggling with the weblogic setup stuff (normally just write the reports), but in em the report server is showing the report continuing to run after the run report window has shown the error. Checked the weblogic configuration and cannot see anything different from the documentation, and cannot see any timeout parameters anywhere that are set to 5 minutes (the time it takes to get the error).

      All of the report logs in the WLS_REPORTS area look to be fine as far as i can tell, reporting successful completion.

      In the web tier OHS component however, messages of type error do appear
      *14-May-2013 12:02:04 BST (Error) … HTTP-503 <remote host IP address> - - [14/May/2013:12:02:04 +0100] "POST /reports/rwservlet? HTTP/1.1" 503 253*

      *14-May-2013 12:07:04 BST (Error) … OHS-9999 ap_proxy: trying POST /reports/rwservlet at backend host <report server IP address>/9002; got exception 'Backend Server not responding'; state: reading status line or response headers from WLS (wrote? Y read? N); not failing over because method not idempotent, referer: http://<server>:8888/reports/rwservlet/getjobid1515?server=<servername>*

      The messages do not appear in the OHS messages log until the failure has happened, but the first has a timestamp that relates to the report start and the second to the time it falls over.

      reports that return within the 5 minute timeframe appear to work fine, including when the same report is used with different parameters that reduce the returned data volume

      I have tried restarting both the reports server and OHS components (but to be honest only vaugely aware what i am doing here) and this had no effect.

      Probably missing something pretty simple, but running out of ideas - can anyone help?

        • 1. Re: Failure of server APACHE bridge:
          Hi GaryW,

          I've seen this quite a few times.

          The Apache Bridge errors occur mostly becuase of a common WebLogic Listener quirk/bug that always happens if unaddressed.

          Try the following on your WLS_FORMS and WLS_REPORTS server (I do this for all 11g Forms/Reports installations): Go into your WLS Admin Console. Go to Environment > Servers. Make sure you are in "Lock & Edit" mode in the console (if you have that option in the upper left hand corner). Open your WLS_REPORTS server under the "configuration" tab. Clear out the value for "Listen Address". Save your chase. I'd do the same for WLS_FORMS - so you don't get those issues either.

          Once the changes are saved, "Activate Changes" (If you have that option in the upper left hand corner). It says reboot is not necessary, but do it anyway. Reboot your WLS_REPORTS and WLS_FORMS servers (If you did this also for WLS_FORMS).

          Let me know if that helps.

          Thank you,

          • 2. Re: Failure of server APACHE bridge:

            I see this error on a customer's installation, but not in connection with long running reports, but after server (machine, not logical Forms/Reports server) reboots.


            The recommended application of patch 12632886 did not solve the issue, but Gavin's solution was helpul.



            • 3. Re: Failure of server APACHE bridge:
              Edward Pang

              I have the same problem. Try increase your timeout from 300 to 1800 in httpd.conf. This is good only for report less ten 30 minutes. If you need more time for the report increase to 3600 for one hour.