2 Replies Latest reply on Nov 22, 2013 2:02 AM by heqiyu

    Sql-developer EA3 Crashed during startup


      Hi,I startup sql-developer on my Ubuntu 13.04,and it crashed with errors:


             "A fatal error has been detected by the Java Runtime Environment:SIGSEGV (0xb) at ...

              JRE version: Java(TM) SE Runtime Environment (7.0_45-b18) (build 1.7.0_45-b18)

              Java VM: Java HotSpot(TM) 64-Bit Server VM (24.45-b08 mixed mode linux-amd64 compressed oops)".


      I already tried "ulimit -c unlimited" before starting to enable write core dump.


      But if i run sql-developer as root user,then it startup normally,so I suspect it's insufficient privilege  when I startup with normal user first time.I have changed the owner of sqldeveloper & Java to myself but it didn't work(which was owned by root previously).


      I don't know how to analyze the core dump nor the error log file created during crash,but I do not want to startup it as root user.So,anybody who can give a solution would be appreciated.