11 Replies Latest reply on Nov 22, 2013 3:18 PM by JeriF

    Weblogic patching in Cloud Control 12cR3


      In "patch recommendation" i  can see that there are 3 available patches for Oracle Weblogic Server. After downloading them and adding in software library I tried to add this patches in a plan. This was not possible because of the following reasons:



      The following patches have not been added to the plan as they do not appear to match the selected target. This will likely result in errors during plan validation. Invalid patches cannot be added to the plan; however, patches with warnings are available for selection and can be added, if you feel the warnings can safely be ignored.



      Invalid Patches (1)








      Patch Name



      Target Type

      Oracle Home




      It renders the plan as non-deployable. : Expected Self Patching not supported for target, found /EMGC_GCDomain/GCDomain


      Oracle WebLogic Domain



      Do you have any ideas how to fix this? Are  these patches really available for the targets? How can I check this? Or do I have to patch manually?

      I have also tried the following:


      searching the patches for my Weblogic Version and platform doesn't give any results.


      The other 2 patches are



      16619891        SU Patch [L51R]: WLS PATCH SET UPDATE        Generic Platform        10.3.6        Security        Oracle WebLogic Server               /EMGC_GCDomain/GCDomain/EMGC_OMS1        Oracle WebLogic Server

        • 1. Re: Weblogic patching in Cloud Control 12cR3

          I've applied these patches manually to my EM environment, using bsu.sh, according to the README documents available with the patches when downloading them manually from MOS.  It does not appear that this patching can be automated using EM12c.


          As I recall, when I applied the L51R patchset update I first had to rollback previous patches from the WebLogic home.

          • 2. Re: Weblogic patching in Cloud Control 12cR3

            Thanks for your help. You were right, I had to remove few patches. After that I was able to install L51R. But still I get the recommendations that I need to install it. I have controlled the log files from REFRESH_FROM_MY_ORACLE_SUPPORT_JOB, this job completed successfully. If I run bsu.sh -gui i can also see that this patch has been applied.

            The other issue is with installing GDFA patch. After installing, the same refresh job fails. I get the ora-00001 (SYSMAN.MGMT_ARU_CERT_ASSOCIATION_PK) violated

            After removing it, everything works fine. I'll just leave it as it is...

            • 3. Re: Weblogic patching in Cloud Control 12cR3

              It took a couple days, but eventually my patch recommendations cleared up and no longer show this patch as applicable to the WebLogic targets.  I'm not sure why you received that error from the MOS refresh job after installing the GDFA patch, though.  I have it installed on my system and my MOS refresh job is completing successfully.  It might be worth it to open an SR to make sure there is not something else strange in your environment.


              oracle:/oracle/oem/Middleware12cR3/utils/bsu> ./bsu.sh -report | grep 'Patch ID'
                    Patch ID.................. L51R
                    Patch ID.................. GDFA
              • 4. Re: Weblogic patching in Cloud Control 12cR3
                Brett Curtis

                I've asked Oracle about this and they did suggest you stay up to date with WebLogic patching. I'm  not sure if that's a legitimate answer. Is the current version of EM12c tested prior to each WebLogic recommended patch release?  Also, EM doesn't even have any persistent stores so not sure that would even be needed at all. I'm still on the fence with this one, sounds like Brian had no issues with this so maybe it's the way to go.

                • 5. Re: Weblogic patching in Cloud Control 12cR3

                  I don't know what happened but after reinstalling the GDFA, the refresh job seems to work fine. The patches are still recommended, although I have installed the L51R last week. Hopefully this gets cleared out.

                  What's also annoying, is that after applying the GDFA I wanted to start the the refresh job, so I have changed it's schedule to "one time immediate". After the job was finished, I wanted to change the schedule, but it was not possible because the job was not scheduled any more. So I created the a new one, with the "create like" option. Does the same thing, but still annoying

                  • 6. Re: Weblogic patching in Cloud Control 12cR3

                    Do you know if any of your patch recommendations are updating?  I guess it wouldn't be obvious unless you have also patched some other OEM-managed system, but if you have done so and those patch recommendations aren't being updated either, take a look at MOS note 1522918.1.  An issue with the to update can break patch recommendations and there's a patch available to fix them (14822626).  It is not clear to me if this patch would also be useful or needed on, but the MOS note mentions "applies to version and later".  I applied this patch while on, before upgrading to, perhaps that's allowing my recommendations to update.


                    (If your Refresh from MOS job output contains the line "...Patch Recommendations Computation is disabled ... skipping..." this might be it.)

                    • 7. Re: Weblogic patching in Cloud Control 12cR3

                      I have already patched one database ("Database Patch Set Update : (16619892)") , and after that the recommendation was gone from the list. So, I don't think  this could be a Problem.

                      This is what I get in log files:


                      [RFMPlugIn_PA] Computing patch advice
                      [RFMPlugIn_PA] Starting to init data; current time = Mon Oct 14 07:16:31 CEST 2013
                      [RFMPlugIn_PA] Completed init data; current time = Mon Oct 14 07:16:31 CEST 2013
                      [RFMPlugIn_PA] Time taken to init data  = [282ms]
                      [RFMPlugIn_PA] No recommendations needed to be evaluated
                      [RFMPlugIn_PA] loadData() Done; Time taken = [2m48s]

                      • 8. Re: Weblogic patching in Cloud Control 12cR3

                        Maybe this will help.  I've just applied the October WLS PSU (patch BYJ1 or 17071663) on my WLS home.  The patch recommendations did not update immediately, but I was able to refresh them by going to the Oracle Home target in EM12c that corresponds to my WL_HOME (/oracle/oem/Middleware12cR3/wlserver_10.3) then clicking the Oracle Home menu, choosing "Configuration", then "Last Collected" from the sub menu.  On the configuration page, click the 'Actions' menu and select 'Refresh'.


                        After that, the patch recommendation for this patch was no longer displayed.

                        • 9. Re: Weblogic patching in Cloud Control 12cR3

                          Thanks for sharing your experience with me..  I have patched my agents yesterday and these patches were immediately out of the recommended patch list.

                          I have also installed the BYJ1 patch, but these patches are still recommended. Actually, before installing the BYJ1 I took a look at my recommendations, and I saw that the new recommended patches are BYJ1 and GDFA. Somehow, the Cloud Control saw what kind of patches were installed... But still, after installing it, it stays the same. I also tried to refresh as you described. Didn't help.

                          Would you be so nice, and paste the exact command, which you used to install the BYJ1? Maybe I'm doing something wrong there...

                          • 10. Re: Weblogic patching in Cloud Control 12cR3

                            I installed BYJ1 as follows:


                            $ cd $MW_HOME/utils/bsu/cache_dir

                            $ unzip ~/p17071663_1036_Generic.zip

                            (answer yes to overwrite files)

                            $ cd $MW_HOME/utils/bsu

                            $ ./bsu.sh -remove -patchlist=L51R -prod_dir=$MW_HOME/wlserver_10.3

                            (that removes the old PSU)

                            $ ./bsu.sh -install -patch_download_dir=$MW_HOME/utils/bsu/cache_dir -patchlist=BYJ1 -prod_dir=$MW_HOME/wlserver_10.3


                            Hope this helps!

                            • 11. Re: Weblogic patching in Cloud Control 12cR3



                              I have the same issue with BYJ1 on EM12cR3.  I applied the BYJ1 patch using SmartUpdate about 10 days ago and EM still reports that EMGC_ADMINSERVER and EMGC_OMS1 need to be patched.  I tried the manual refreshes suggested in this thread and it did not clear the Alert.  I also had a case open with MOS about this and was told the Alert wasn't clearing because "EM does not report the minor versions of the WLS (i.e. vs the actual:" and the case was closed with "no fault found".   I did request that the issue be raised for further review with the proper team.  My thinking is that if EM is going to Alert on a missing patch, then it should also clear the Alert when the patch is applied.


                              I do plan to investigate BrianP's reference to MOS note 1522918.1 and patch 14822626 though and see if that might help.