9 Replies Latest reply on Dec 18, 2013 5:08 PM by Shivendra Narain Nirala

    Oracle instance becomes idle frequently because of j000 and w000 process

    Tushar Lapani

      I am using Oracle 11g R2 on linux Redhat 5.2 . We are also using APEX 4.2 on oracle database. My instance is getting idle frequently. But weird thing is that though my instance had become idle, my oracle APEX applications are working fine and i can execute all type of queries form SQL Command prompt of APEX. Even I can access some schemas to which I am already connected from SQL developer but i can't establish new connection for any schema. When I try to connect with any schema it returns error of "oracle instance is idle" I checked the alert_<SID>.log file and it states below.

      1.kkjcre1p: unable to spawn jobq slave process

      2.Process W000 died

      3.Process j000 died

       

      My parameter file contains following configurations.

      open_cursors=300

      processes                = 150

      sga_max_size             = 2400M

      sga_target               = 2208M

      memory_target            = 2592M

      memory_max_target        = 2688M

      pga_aggregate_target      = 384M


                         

           pga_aggregate_target (384M) + sga_max_size (2400M) > memory_max_target (2688M)

           pga_aggregate_target (384M) + sga_target (2208M) < memory_max_target (2688M) and

           pga_aggregate_target (384M) + sga_target (2208M) > memory_target (2688M)


       

      The output of free -m command is as follow.

                        total       used       free     shared    buffers     cached

      Mem:          5973       5923         49          0        143       3338

      -/+ buffers/cache:       2442       3531

      Swap:         2047        287       1760

       

      The same error was occurred before few days and we restarted server as solution and it worked. But now same error is raised again.

       

      when I try to start the instance in mount mode it hangs and returns error like "end of communication channel".

       

      So, please let me know what could be the problem and whats is its solution.

       

      Thanks & Regards

      Tushar Lapani