4 Replies Latest reply on Dec 6, 2013 3:19 PM by JulianG

    JET install and ZFS failure


      Hi - I have a JET (jumpstart) server that I've used many times before to install various Solaris SPARC servers with - from V240's to T4-1's. However when I try to install a brand new T4-2 I keep seeing this on screen and the install reverts to a manual install:


      svc:/system/filesystem/local:default: WARNING: /usr/sbin/zfs mount -a failed: one or more file systems failed to mount


      There's been a previous post about this but I can't see the MOS doc that is mentioned in the last post.


      The server came pre-installed with Sol11 and I can see the disks:



             0. c0t5000CCA016C3311Cd0 <HITACHI-H109030SESUN300G-A31A cyl 46873 alt 2 hd 20 sec 625>  solaris



             1. c0t5000CCA016C33AB4d0 <HITACHI-H109030SESUN300G-A31A cyl 46873 alt 2 hd 20 sec 625>  solaris




      If I drop to the ok prompt there is no hardware RAID configured and raidctl also shows nothing:


      root@solarist4-2:~# raidctl



      The final post I've found on this forum for someone with this same problem was "If you have an access to MOS, please check doc ID 1008139.1"


      Any help would be appreciated.


      Thanks - J.

        • 1. Re: JET install and ZFS failure

          Hi Julian,


          I'm not convinced that your problem is the same one that is described in this discussion:


          Re: Problem installing Solaris 10 1/13, disks no found


          Do you see the missing volume message (Volume 130 is missing) as described in this thread?


          A google search shows that there are issues with for a T4 Solaris 10 install due to a network driver problem and also if the system is using

          a virtual CD or device through a LDOM.


          What happens when you boot your T4 from the installation media or server into single-user mode? You say that you can see the disks, but can  you create a ZFS storage pool on one of these disks manually:


          # zpool create test c0t5000CCA016C3311Cd0s0

          # zpool destroy test


          For a T4 and a Solaris 10 install, the disk will need an SMI (VTOC) label, but I would expect a different error message if that was a problem.


          Thanks, Cindy

          • 2. Re: JET install and ZFS failure

            Thanks Cindy - I had a quick look at this yesterday and now I'm not sure it's T4 related. Going back to basics I tried to reinstall a V125 I had lying around and this fails with the same problem. I don't use the build server much, last built some servers about 6 months ago. All I did this time was refresh the Solaris media with Solaris 10 64bit SPARC U11, previous was U10. The V125 client template didn't even reference ZFS, I chosen to use UFS this time. I'm going to take a 3rd look today and hopefully work it out !!




            • 3. Re: JET install and ZFS failure

              Actually had a bit of a breakthrough with this, so tidied up my client templates on both the V125 and T4-2 client and whilst the V125 client now works the T4-2 client now fails with this:


              {0} ok boot net - install

              Boot device: /pci@400/pci@1/pci@0/pci@4/network@0  File and args: - install

              100 Mbps full duplex Link up

              Requesting Internet Address for 0:10:e0:3e:f:6c

              100 Mbps full duplex Link up

              100 Mbps full duplex Link up


              seek failed


              Can't mount root


              ERROR: /pci@400/pci@2/pci@0/pci@e/scsi@0: Last Trap: Fast Data Access MMU Miss


              {0} ok



              So a completely different error, I've no idea where this error has come from however.

              • 4. Re: JET install and ZFS failure

                Bit of a mystery this one, I've been through my JET client config several times making minor changes to tidy things up for our T4-2 servers and they build now. I still see "svc:/system/filesystem/local:default: WARNING: /usr/sbin/zfs mount -a failed: one or more file systems failed to mount" but it doesn't seem to stop the build from working. I also randomly get the fail above, but it I just run "boot net - install" again it works? So at the moment ignoring the few bits of odd behaviour all is well.


                One last thing is should I expect the build to be fully automated? Every time I run the install it keeps asking me about the "Date and Time" and I have to F2 to confirm this, the system identification is then complete and the install starts. If I could get rid of that the build would be fully automated and all I would have to do is type "boot net - install"


                Thanks - Julian.