2 Replies Latest reply: Dec 12, 2013 2:46 AM by wrozansk RSS

    Problem with refreshing

    wrozansk

      Hello,

       

      I am struggling with what seems should have been extremely easy.

       

      I am trying to implement a search on a page in apex. The idea is that when a user inputs a string into a page item (Text Field named P21_TICKETNUMBER) and hits the "Find" button, the report on that page will refresh.

       

      The report itself contains a statement:

      where (a.ticketnumber = :P21_TICKETNUMBER)
      

       

      What I've been trying to do it to use a Dynamic Action that would refresh the region with the report, but it does not do anything. The report shows "No Data Found" all the time.

       

      I tried a second approach, with the "Find button" programmed to redirect to the page I am now in (page 21) and setting the value of P21_TICKETNUMBER2 (which was created solely for that purpose and the report modified to look at this item) with &P21_TICKETNUMBER. (which is what the user inputs). The problem with this approach is that when the page refreshes (I mean, when the redirect kicks in), there is no value in P21_TICKETNUMBER2 and thus the report still shows "No Data Found"

       

      Like I said, I am certain this is very easy to implement. I have no idea why is it so hard for me. Please advise.

       

      Kind regards,

       

      Wojciech

        • 1. Re: Problem with refreshing
          fac586

          Please update your forum profile with a real handle instead of "981911". Always state which APEX version you are using when asking a question.


          Include P21_TICKETNUMBER in the Region Definition > Source > Page Items to Submit property in the report region definition. The item value will then be submitted and stored in session state when the report is refreshed.

           

          Create a Dynamic Action to refresh the report region when the Find button is clicked.

          • 2. Re: Problem with refreshing
            wrozansk

            Hello,

             

            Thank you for your reply. Though it did not fully resolve my problem, you did point me in the right direction and I was eventually able to find a solution.

             

            Kind regards,

             

            Wojciech