1 Reply Latest reply: Dec 27, 2013 12:43 AM by Suntrupth RSS

    Reg: Charset issue -

    ranit B

      Hi Experts,


      I have a database say 'X' whose charset is - WE8ISO8859P1

      After SQL*Loader inserts data into X from a windoze box, when queried from X some characters are displayed as reverse question mark.


      0x27 - standard ASCII apostrophe (')
      0x91 - left single quotation mark (‘)
      0x92 - right single quotation mark (’)
      0xb4 - acute accent (´)

      Windoze box has charset - WE8MSWIN1252


      1. What is the possible issue? Is it the incompatibity of character sets between them?

      2. While fetching can I use CONVERT function to fix and display this properly?

      3. Just trying to understand - is the problem while inserting the data or just while displaying?


      Please give some pointers in this regard.


      -- Ranit

      ( on Oracle )

        • 1. Re: Reg: Charset issue -

          Hi Ranit,


          What is the encoding or the characters that you have inserted? Are they characters which belong to WE8ISO8859P1 encoding?


          What is the NLS_LANG defined in your windows environment?


          What is the characterset set in the controlfile of the SQL*Loader if you have defined one. If you haven't defined one in the controlfile then the NLS_LANG then sqlldr uses the characterset defined by the NLS_LANG.


          ++ Note that the CHARACTERSET (or, if not defined, for sqlldr the NLS_LANG) needs to reflect the characterset of the FILE you try to load, not the database NLS_CHARACTERSET.


          Can you have SQL Developer (a unicode tool) installed on your DB server and check if you still observe reverse question mark?