3 Replies Latest reply: Jan 2, 2014 7:05 AM by Alan_S RSS

how to relax the constraints of the dependent package

renfeng416 Newbie
Currently Being Moderated

Updating Multiple Packages

Packages might have cross-dependencies and, thus, require updating at the same time. The packaging software will enforce a consistent image on the system: If it cannot satisfy the dependencies, the packages will not be modified. If such a dependency exists, you need to relax the constraints of the affected packages.

 

 

The message reported by the packaging software will be of the following form:

 

# pkg update package_name@0.5.11-0.175.0.2

Creating Plan \               

pkg update: No matching version of package_name can be installed:

   Reject:  pkg://solaris/package_name@0.5.11,5.11-0.175.0.2.0.3.0:...

   Reason:  All versions matching 'require' dependency

   pkg:/otherpackage@0.5.11,5.11-0.175.0.2.0.3.0 are rejected

 

how to relax the constraints of the dependent package

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points