2 Replies Latest reply: Jan 21, 2014 11:38 AM by tx100118 RSS

Any recourse in failed 11gR2 installation?

tx100118 Newbie
Currently Being Moderated

My installation was on step 15 of 16 (11.1.2.2 on Oracle Linux 6) when it failed.  It failed when trying to start the Reports Service via opmnctl.  Unfortunately I had leave the facility and Cancel the installation.  After digging around in the log files this morning, I discovered the pre-req check didn't catch the likely problem that my motif package needed updating. The documentation mentions SuSE has this problem but apparently it isn't just SuSE. 

 

What are my options at this point?  Full deinstall & start over?   I tried config.sh but it detects the previous (?incomplete?) configuration.  I'm wondering if the *real* configuration is possibly complete and all I need to do is execute a few more normal commands for starting up the reports server???????  Based on the screenshot behind the link below, it was at approximately 65% of the Configuration step.

 

https://drive.google.com/file/d/0Bxt0E2fvf_vBc3BLQjh6ZnQyWkE/edit?usp=sharing

  • 1. Re: Any recourse in failed 11gR2 installation?
    Michael Ferrante (Oracle) Guru Moderator
    Currently Being Moderated

    What you do next will depend on many factors that only you can answer.  Personally, my opinion is that if you don't have any other Oracle products installed, I would delete the current installation and start over.  On Unix it's as simple as deleting directories.  Delete the "Middleware" directory, the Oracle inventory, and if one was created, the "bea" directory.  Then before going further, read the System Requirements documentation and the Install Guide.

     

    http://docs.oracle.com/cd/E48391_01/index.htm

     

    Additional tips:

     

    Do not begin the installation until you have completed the following first:

     

    1.  Review and follow the Installation and System Requirements Guide(s)

    2.  Ensure that the machine has a static IP address and/or has had the system hosts file properly configured (refer to the Sys Requirements Guide)

    3.  Install Java 6 JDK (ensure you install a 64bit version if the OS is 64bit).  I do not recommend installing WLS 10.3 and FMw 11.1 using Java 7.  You can upgrade the version later if desired.

    4.  Install Motif (refer to the Sys Requirements Guide - section 6.2 to determine exactly which version is needed)

  • 2. Re: Any recourse in failed 11gR2 installation?
    tx100118 Newbie
    Currently Being Moderated

    I ended up doing a full wipe and started over before your reply. I would like to add (for others as a reference later) that ->

     

    1. I tried to JUST deinstall the Forms/reports services software via ./runInstaller -deinstall from the oui directory.  I removed the instance. Ran deinstall again on the Oracle Home.  I forgot to stop all the processes between those two steps though.  I realized this much later.  

     

    I also learned that the Forms/Reports Service configure step tries to create the ClassicDomain again inside WLS.  Since it existed and I didn't really know the dependency on ClassicDomain, I punted, got the ball back and scored on the fresh install.  In hindsight after reviewing the WLS Domain creation manual and reflecting on my knowledge of Glassfish, I likely could have specified a different domain name other than ClassicDomain.

     

    2. since I also decided to change the directory where my inventory was kept, I had to remove the OraInst.loc file in /etc

     

    Thanks for being involved in this forum, Michael.  FYI - I'm performing a mock upgrade to 11gR2 from 10gR2.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points