1 2 Previous Next 22 Replies Latest reply: Feb 20, 2014 8:12 AM by BSalesRashid Go to original post RSS
      • 15. Re: Trim abnormal Behavior.
        Jonathan Lewis

        You've given us a description of tablex - but you're inserting into itemcobranca2, so it would be worth seeing the defintion of that table too.

        A call to dbms_metadata.get_ddl() would be the most informative option.

         


        Regards

        Jonathan Lewis

        • 16. Re: Trim abnormal Behavior.
          jgarry

          I was kind of wondering if the select * was giving a different column order, but couldn't quite figure how trim would change that from a working one.  There may be something else we are not being told, perhaps the order in which things worked and didn't work on which computer.  If it is as simple as the second table has different definitions in two environments, that would be a face-palm.

          • 17. Re: Trim abnormal Behavior.
            Jonathan Lewis

            I was thinking more along the lines of varchar2() / nvarchar2() - the 4000 limit is bytes not characters.

             

            We haven't been told that the problem doesn't (didn't) exist before the trim() - or whether a change from working to non-working is reproducible by applying a trim().

             

            Regards

            Jonathan Lewis

            • 18. Re: Trim abnormal Behavior.
              JuanM

              Hi, I think this is the big thing we are missing.

              BSalesRashid wrote:

               

              "The user application prints a report with many blank spaces,

              On homologation environment, the user asked me to execute this script:"

              .

              .

              .

               

              jgarry wrote:

               

              Perhaps the data in there is being expanded due to character set issues?

               

              Juan M wrote:

              Are the tables itemcobranca2 and tablex in the same database?

               

              Jonathan Lewis wrote:

               

              I was thinking more along the lines of varchar2() / nvarchar2() - the 4000 limit is bytes not characters.

               

              IMO, there are two databases involved with distincts character sets.

               

              Regards

               

              Juan M

              • 19. Re: Trim abnormal Behavior.
                BSalesRashid

                Hi guys, sorry bout the delay.

                 

                Here's the deal: itemcobranca2 is the same table than tablex, i used tablex because i was trying to hide the table's name. Sorry, i couldn't keep.

                 

                The user sent me that pl/sql code, to execute in HOMOLOGATION environment, and that is the same database. We're talking about 1 database here.

                 

                jgarry: What would be this character set issue, once there's no changes in character sets.

                 

                Juan M: They are the same table. I just called tablex on the beginning because i won't give the table's name. But i couldn't keep it.

                 

                Jonathan Lewis: Fine, my mistake. It is for sure the number of bytes.

                 

                But this is not a problem anymore (the environment changed, machines, new refresh was made), if you want to discuss this, we may do it.

                • 20. Re: Trim abnormal Behavior.
                  BSalesRashid

                  And thanks a lot.

                  • 21. Re: Trim abnormal Behavior.
                    jgarry

                    The character set issue would normally be between databases, although there may be issues from changing environments exporting and importing to the same database.  You are using the Oracle definition of database, right?  (As opposed to other engines call schemata a database.)

                     

                    Committing within a loop may cause problems, it is hard to say whether that is related to this problem.

                     

                    I think you would have to come up with a complete demonstration including create table and insert data statements to replicate this for anyone to help further.  Support would probably just tell you to patch to the latest patch level on a fully supported version.

                    • 22. Re: Trim abnormal Behavior.
                      BSalesRashid

                      Hi,

                      The thing is: all this happened in one database only (homologation), if it had worked correctly, i would do on production database. So, there was no problem with character set issue.

                      Yes, i am using Oracle definition of database. I think the problem was with Commiting in a loop as well, but i would like to make sure of that, or know the reason..

                       

                      The database is 10.2.0.1 standard, and the enterprise that owns it won't upgrade it, so, no chance doing that.

                       

                      As i said, that problem is gone, a duplicate from production database to homologation database have happened. But it's ok discussing that.

                       

                      Thanks anyway.

                      1 2 Previous Next