13 Replies Latest reply on Feb 12, 2010 4:45 AM by 753316

    Error Starting ORMI-Server


      I am using 10g Enterprise Edition on Linux Advance Server 3.0 and Enterprise Manager.
      I get the following error when starting up each Container I have created.

      04/01/14 10:25:56 Error starting ORMI-Server. Unable to bind socket: Address already in use
      04/01/14 10:25:59 java.lang.NullPointerException
      04/01/14 10:25:59 at com.evermind.server.rmi.RMIServer.run(RMIServer.java:470)
      04/01/14 10:25:59 at com.evermind.util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:186)
      04/01/14 10:25:59 at java.lang.Thread.run(Thread.java:534)

      I changed the port number ranges via EM and in "opmn.xml" to limit each container to its own range, but no success.
      Even i set the specific port for each service.

      M. Tahir.
        • 1. Re: Error Starting ORMI-Server
          I have exactly the same problem. Are you able to find a solution?. I am using Oracle10gAS(9.0.4) on Redhat ES 3.0.
          • 2. Re: Error Starting ORMI-Server
            Hi, I assume you are using host="". Try using your real IP. This worked for me.
            • 3. Re: Error Starting ORMI-Server
              Please explain, where to use IP of machine.
              If on client side, i m using IP of server machine.

              • 4. Re: Error Starting ORMI-Server
                Still the same problem even if I specify the host as the machine IP, adding the port no in "port = '3701'"

                Question - When installing the Linux Server - What do you specify when doing the firewal security - there are 3 options. I chose medium security - can that not be part of the problem?

                • 5. Re: Error Starting ORMI-Server

                  we have the same problem.

                  What ist the solution?

                  Is there any workaround for the problem (patch, ..)?

                  • 6. Re: Error Starting ORMI-Server
                    I too got the Same Problem?. Could any one found the solution for this problem.
                    Plz. Help us in solving the problem.
                    • 7. Re: Error Starting ORMI-Server
                      Modify the config/rmi.xml file to have the host attribute in the tag as follows:

                      <rmi-server port="23791" host="server-ip-address">

                      After that, place the log4j-your-jdev-version.jar in appserverhome/j2ee/home/lib folder.

                      Restart the server. The bind problem would disappear.

                      Hope this solves your problem :-)

                      • 8. Re: Error Starting ORMI-Server
                        hi ramesh,
                        this is sateesh. I only posted the above request before i found the solution. but with different trials i got that at last.
                        • 9. Re: Error Starting ORMI-Server
                          hi ramesh,
                          this is sateesh. I only posted the above request
                          before i found the solution. but with different
                          trials i got that at last.
                          Hi Sateesh,

                          i'm using the Oracle 10g AS (9.0.4) on RedHat Linux 3.0 Advanced Server.
                          I've formatted my machine, installed redhat and then 10g AS. There are no other softwares installed on my machine.

                          After installation, I've created an Instace of OC4J server using IAS console, started the instance and got a message saying my instance has been started. But when i look at the log file in %ORACLE_HOME%/opmn/logs i got a message saying "Error starting ORMI-Server. Unable to bind socket: Address already in use".

                          I've searched this forum for this and did all the kinds of modifications suggested by others and found no success. U said that u've tried other way and found the solution. Could you please help me out with the solution. I've tried stopping the default server instance being created at the time of 10 gAS installation. When i looked at the ports in use for the application server, its listing different ports for JMS, RMI and AJP but the same port for Oracle HTTP Server as 7778.

                          P.S.: this is not only for sateesh, but for any one who could help me out with the solution.

                          Please help me ASAP as its urgent for me and I've spent last 5 days for this.
                          Any kind of help regarding this would be highly appreciated.

                          • 10. Re: Error Starting ORMI-Server
                            Hi Ramesh,

                            you've mentioned to place log4j-your-jdev-version.jar in appserverhome/j2ee/home/lib folder.. where to find the jar file that you are talking about and what is the relation between log4j jar and server start up?

                            Please help me ASAP
                            • 11. Re: Error Starting ORMI-Server
                              I solved the problem by changing /etc/hosts. Don't let the server to resolve servername to the IP

                              Such as

                     localhost.localdomain localhost
                     laappt6.maximus.local laappt6
                              • 12. Re: Error Starting ORMI-Server
                                how did you change your /etc/hosts file? i have an entry in this file as follows:

                       ROBBROS-QA localhost.localdomain localhost

                                here ROBBROS-QA is my hostname. What changed do i need to do to solve the problem with starting ORMI Server. Please help me ASAP

                                Thank you,
                                • 13. Re: Error Starting ORMI-Server
                                  Hey Ramesh,

                                  i was struck with the same problem and ur solution helped me.. thanks a lot :)