11 Replies Latest reply: Mar 14, 2014 4:34 AM by Janet RSS

    sqldev4 does not work with oci and the 11.2.0.4 client

    Laurent Schneider

      When I start SQL Developer 4.0.1.14 with an Oracle 11.2.0.4 client, it crashes. The workaround is to replace sqldeveloper\jdbc\lib\odbc6.jar with the 11.2.0.4 version

       

      Otherwise, it crashes at the time you try to connect.

       

      EXCEPTION_ACCESS_VIOLATION (0xc000005) at pc=0x00000000063d14bc7, pid=9800, tid=9596

      Problematic frame :

      V [jvm.dll+0123bc7]

      Core dump

      ...

      j oracle.jdbc.driver.T2CConnection.t2cCreateState([BI[BI[BI[BI[BI[BI[BISI[S[B[B[J)I+0

      ...

       

       

      PS: Do you want me to open a bug?