7 Replies Latest reply: Mar 18, 2014 7:35 PM by Gerard RSS

    Problems to display image in list region

    Gerard

      Hello everyone

       

      I have problems to display an image not coming from the worksapce in a list

       

      Create a region type list using the vertical image list template and I want the image that is displayed in each entry of the list come from the web server, I do this easily in a report in the following way:

      <img src="/apps_resources/APP121/glyphicons_halflings_080_circle_plus.png" alt="">

       

      But it does not work on a list, I've tried in different ways and none work

       

      Does anyone know how to do this correctly?

       

      Best regards

       

      Apex 4.2.0

      Oracle 11 g R2

      Apexlistener 2.6 deployed in tomcat

        • 1. Re: Problems to display image in list region
          fac586

          How "doesn't it work" in a list?

           

          How are the list entries defined?

           

          How is the list rendered in the page source?

           

          Suggest you reproduce the problem with an example on apex.oracle.com.

          • 2. Re: Problems to display image in list region
            Gerard

            Thank you very much for your quick response!

             

            I guess my question is not very clear, I will try to make it clearer.

             

            The first element of the list does not display the image because the url is incorrect, the rest of the list items correctly display the images

             

            I have tried different ways to refer to the image, but apex automatically adds the prefix / i-4.2 and that makes it generate an invalid url

             

            The correct url would be: https://cyaprod03.carrillo.local:8443/cya_apps_resources/APP126/glyphicons_341_briefcase@2x.png

             

            This is the source code of the list region

            <div class="uImagesList_cya uVerticalImagesList clearfix">

              <ul>    <li>

                  <a href="f?p=126:1:15632038818164:REP_ACT_X_CASO:NO:1:P1_VISTA_ACTUAL:REP_ACT_X_CASO">

                   <img alt="" src="/i-4.2/cya_apps_resources/APP126/glyphicons_341_briefcase@2x.png"> ***THIS URL IS INVALID, THE PREFIX / i-4.2 IS NOT CORRECT IN THIS CASE**

                    <span>Administración de casos</span>

                  </a>

                </li>    <li>

                  <a href="f?p=126:1:15632038818164:REP_ACT_X_COL:NO:1:P1_VISTA_ACTUAL:REP_ACT_X_COL">

                    <img alt="" src="wwv_flow_file_mgr.get_file?p_security_group_id=1750701988192135&amp;p_fname=glyphicons_037_credit@2x.png">

                    <span>Liquidación de casos

            </span>

                  </a>

                </li>    <li>

                  <a href="f?p=126:1:15632038818164:REP_ACT_X_ESTADO:NO:1:P1_VISTA_ACTUAL:REP_ACT_X_ESTADO">

                    <img alt="" src="wwv_flow_file_mgr.get_file?p_security_group_id=1750701988192135&amp;p_fname=glyphicons_029_notes_2@2x.png">

                    <span>Cotizaciónes de servicios</span>

                  </a>

                </li>    <li>

                  <a href="f?p=126:1:15632038818164:REP_DET_ACC_X_ACTI:NO:1:P1_VISTA_ACTUAL:REP_DET_ACC_X_ACTI">

                    <img alt="" src="wwv_flow_file_mgr.get_file?p_security_group_id=1750701988192135&amp;p_fname=glyphicons_019_cogwheel@2x.png">

                    <span>Configuración de servicios</span>

                  </a>

                </li>  </ul>

            </div>

            • 3. Re: Problems to display image in list region
              fac586

              How are the list entries defined?

              I have tried different ways to refer to the image, but apex automatically adds the prefix / i-4.2 and that makes it generate an invalid url

              What have you tried? Provide exact details.

               

              Can you reproduce the problem with an example on apex.oracle.com?

              • 4. Re: Problems to display image in list region
                Gerard

                Sorry for my poor English, I think that I do not correctly expressed the problem.

                 

                I will follow your advice, i will reproduce the problem on page apex.oracle.com

                 

                Thank you very much for the interest

                • 5. Re: Problems to display image in list region
                  Gerard

                  I made an application which demonstrates the problem with lists, this is the link http://apex.oracle.com/pls/apex/f?p=83363

                   

                  The first two entries in the list displayed image without any problem, they are images of the workspace. The other two entries do not show image, but the url where I make reference is valid. Apex adds the prefix /i/ to the url of image and that makes it invalid.

                   

                  The user is guest and the password is invitado1

                   

                  I hope you can help me.

                   

                  regards

                  • 6. Re: Problems to display image in list region
                    fac586

                    The problem is that the image prefix is hard coded into the src URLs in the Vertical Images List template. Make a copy of the template, edit it to remove the #IMAGE_PREFIX# substitution string from the List Template Current and List Template Noncurrent definitions, and use the new template for your list region.

                    • 7. Re: Problems to display image in list region
                      Gerard

                      Thank you very much for your help, I will make the change as you indicate.

                       

                      Thanks a lot