5 Replies Latest reply: Mar 20, 2014 2:35 PM by Robert Chase RSS

    ETH2 showing instead of ETH1

    Jimbo


      Hi,

       

      I have just replaced a faulty NIC in my server

       

      When I do ifconfig it shows

       

      eth0      Link encap:Ethernet  HWaddr 00:19:BB:DE:9C:10
                inet addr:192.168.0.5  Bcast:192.168.0.255  Mask:255.255.255.0
                inet6 addr: fe80::219:bbff:fede:9c10/64 Scope:Link
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
                RX packets:4480 errors:0 dropped:0 overruns:0 frame:0
                TX packets:6625 errors:0 dropped:0 overruns:0 carrier:0
                collisions:0 txqueuelen:1000
                RX bytes:293552 (286.6 KiB)  TX bytes:7711608 (7.3 MiB)
                Interrupt:17

      eth2      Link encap:Ethernet  HWaddr 00:E0:4A:08:F3:56
                inet6 addr: fe80::2e0:4aff:fe08:f356/64 Scope:Link
                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
                RX packets:0 errors:0 dropped:0 overruns:0 frame:0
                TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
                collisions:0 txqueuelen:1000
                RX bytes:0 (0.0 b)  TX bytes:258 (258.0 b)

      lo        Link encap:Local Loopback
                inet addr:127.0.0.1  Mask:255.0.0.0
                inet6 addr: ::1/128 Scope:Host
                UP LOOPBACK RUNNING  MTU:65536  Metric:1
                RX packets:214 errors:0 dropped:0 overruns:0 frame:0
                TX packets:214 errors:0 dropped:0 overruns:0 carrier:0
                collisions:0 txqueuelen:0
                RX bytes:17436 (17.0 KiB)  TX bytes:17436 (17.0 KiB)

       

      It seems to have replaced ETH1 with ETH2. Yet it has not assigned the Static IP I have given the NIC

       

      When on the Console I look at SYSTEM - PREFERENCES - NETWORK CONNECTIONS I see

       

      System eth0 - this is set to the IP address above and the MAC address

       

      System eth1 - this is set to the IP I want ( 192.168.2.97 ), has the Method set to Manual and also has Connect Automatically ticked

      However I notice that the MAC address for ETH1 in the system console ( 00:E0:4A:08:9C:4D ) is different from that show by ifconfigfor ETH2 ( 00:e0:4A:08:F3:56 )

       

      Q1. Why is ifconfig showing something completrly different i.e. ETH2 instead of ETH1 ?

       

      Q2. Why is ifconfig only showing inet6 for eth2 and not inet ( i.e. IP v4 )

       

      Q3. Is the Server console holding onto the old MAC address of the failed NIC ? Is there some sort of Discovery process I need to run ? Or do I need to manually change this MAC address on the server console for ETH1 to be the new MAC address i.e. that shown under ETH2 of ifconfig above ?

       

      Any help appreciated

      Jim

        • 1. Re: ETH2 showing instead of ETH1
          Jimbo

          Manually setting the MAC address of ETH1 in the SYSTEM - PREFERENCE - NETWORK console causes ETH2 in ifconfig to correctly pick up the statically assigned IP address !

           

          So it looks as if ifconfig shows ETH0 and ETH2, will the SYSTEM - PREFERENCE - NETWORK on the Console shows ETH0 and ETH1 for the same thing !

           

          Jim

          • 2. Re: ETH2 showing instead of ETH1
            Robert Chase

            Jimbo,

             

            Could you provide the contents of the following config files?

             

            /etc/sysconfig/network-scripts/ifcfg-eth0

            /etc/sysconfig/network-scripts/ifcfg-eth1

            /etc/sysconfig/network-scripts/ifcfg-eth2

            • 3. Re: ETH2 showing instead of ETH1
              Jimbo

              Robert - there was only  :

               

              ifcfg-eth0 and ifcfg-eth1, there was no ifcfg-eth2

               

              They had the correct MAC addresses in them ( i.e. eth1 held the correct MAC of the new NIC ). So it looks as if the SYSTEM - PREFERENCE - NETWORK updates these files ok

               

              However I noticed that it must not update the UDEV rules files for network cards

              I found that /etc/udev/rules.d/70-persistent-net.rules contained the old MAC address against an ETH1 entry but also another ETH1 entry with the new MAC address.

               

              It looks as if ifconfig reads the first entry it comes across for ETH1 and realises that this card is not installed.

              As soon as I cleaned up this file, IFCONFIG then correctly shows ETH0 and ETH1

               

              thanks,

              Jim

               


              • 4. Re: ETH2 showing instead of ETH1
                Dude!

                The following recently discussed in another thread: Re: How to start eth1 on boot. should solve your questions about eth1.

                • 5. Re: ETH2 showing instead of ETH1
                  Robert Chase

                  Jimbo.  Glad you were able to get it resolved!