4 Replies Latest reply: Mar 24, 2014 2:19 PM by KTM RSS

    Unable to create connection to the Oracle Java Cloud server


      Hi All,


      I am trying to deploy simple ADF application to Oracle Cloud.


      I am successfully transfered HR schema to my database cloud service and now am trying to create a connection to the oracle java cloud service instance

      but it is failing to create a connection to the cloud server and throwing the error message

      Testing Cloud-Admin                    ... failed.

      listApplications failed.

      Check username, password, domain, instance.

      Check cloud sdk location & version: Tools->Preferences->Oracle Cloud



      0 of 1 tests successful.


      MyService details are as follows



      JDEV : Build JDEVADF_11.


      Cloud version:


      I am pretty sure , i am using proper credentials since am able to java cloud service console with same credentials.


      Please help me out on this.



        • 1. Re: Unable to create connection to the Oracle Java Cloud server

          Perhaps check your proxy setting in Jdev.  Tools>preferences>Web Browser and Poxy.


          The other thing the service console is not the same as the service itself.

          • 2. Re: Unable to create connection to the Oracle Java Cloud server

            Hi Thanks for the reply


            I check check-box of proxy settings and restarted the jdeveloper and tried again but still it throws the same error? one doubt here...what all we need to include / exclude in our proxy settings...

            and the I tried providing service name as both java and javatrial8477 but no luck i followed the same steps which are mentioned in the below document

            Part 2: Deploying ADF Applications to Oracle Java Cloud

            Do i need to do any other configuration? Or i can directly deploy my ear file to java service console rt instead of creating connection tot the server from IDE.



            • 3. Re: Unable to create connection to the Oracle Java Cloud server
              Jani Rautiainen-Oracle

              Check the location of the SDK by navigating "Tools -> Preferences -> Oracle Cloud -> Java Cloud Service SDK", navigate the directory and go to "lib" sub directory. Check the version with command:

              java -jar javacloud.jar -version

              Oracle Cloud Java Service Deployer Tool.



              What is the version displayed for you ? If something else than "" try downloading the latest SDK, unzip it somewhere and point your Jdev to the new version.


              Jani Rautiainen

              Fusion Applications Developer Relations


              • 4. Re: Unable to create connection to the Oracle Java Cloud server

                Hi Jani,


                Thanks for the reply...I tried as you said and but i received some thing like shown below


                D:\Oracle\MiddlewareCloud\jdeveloper\cloud\oracle-javacloud-sdk\lib>java -jar j

                vacloud.jar -version

                Exception in thread "main" java.lang.UnsupportedClassVersionError: oracle/cloud

                paas/client/cli/Main (Unsupported major.minor version 50.0)

                        at java.lang.ClassLoader.defineClass0(Native Method)

                        at java.lang.ClassLoader.defineClass(ClassLoader.java:539)

                        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:1


                        at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)

                        at java.net.URLClassLoader.access$100(URLClassLoader.java:55)

                        at java.net.URLClassLoader$1.run(URLClassLoader.java:194)

                        at java.security.AccessController.doPrivileged(Native Method)

                        at java.net.URLClassLoader.findClass(URLClassLoader.java:187)

                        at java.lang.ClassLoader.loadClass(ClassLoader.java:289)

                        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)

                        at java.lang.ClassLoader.loadClass(ClassLoader.java:235)

                        at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)


                i downloaded latest JDK from the link which you have provided and point my jdev to new JDK and am successfully able to connect to cloud server