1 Reply Latest reply: Apr 2, 2014 10:05 AM by 1922654 RSS

    Workflow activity stuck at Custom Nodes and is in Active Status


      Hi Team,


      We have one issue with our Custom Order Management--> Order  Booking workflow. Can you please help us.




      Our Workflow Activities are in the following sequence.


      Start --> Activity A ---> Activity B --> Activity C --> End


      Code at Activities A, B, C involves Third part tool Integrations which involves business events, invoking Https Urls with Req/Res Xmls


      Ideally whenever an issue encounters at any one of these nodes, either workflow should go back or should proceed further.

      But in our case, process gets stuck at some Node (either A, B or C) with Activity status as ACTIVE. Upon checking Workflow diagram, seems there is no 'Y' or 'N' signal from any one of the above activities, once processes at respective Activity's gets completed.


      Can you please review this issue and suggest if anything could be checked.


      1) We came across some hint in google and found that missing COMMIT statement could be the issue.

           But we checked our custom code and there is no issue with COMMIT.

      2) We have even checked the FINAL RETURN status at each of the Activity's by adding debug messages and we could see that the return value is appropriate but not sure what is causing this



      Upon retrying the Activity from Workflow Administrator resp, the same activity (that is stuck before) is getting Completed Normally.

      Also this is an intermittent issue and not sure, if this is happening inconsistently due to some environment params or some load related.


      Request you to review the problem and suggest if anything needs to be checked.


      Thank you,

      Lokesh G

      Oracle Apps Consultant