4 Replies Latest reply: Apr 15, 2014 2:42 PM by 951803 RSS

    Integrate Discoverer 11g with OAM 11g

    951803

      Hi,

       

      We setup SSO for Discoverer and now we want to use a VIP so our Base URL needs to be changed. Currently we access Discoverer using the below URL: http://discovererdev01:8888/discoverer/plus we need to use the below URL instead, rather than using the machine name we are using the alias http://discod.mycomapny.com/discoverer/plus Inside OAM we changed the based URL to http://discod.mycomapny.com copied over the new mod_osso.conf to the discoverer OHS restarted OHS but it gives us SSO Error it’s not recognizing the new url.

       

      Is there anything else we need to do. Here is the error we get

       

      System error. Please re-try your action. If you continue to get this error, please contact the Administrator.

       

      Thanks

        • 1. Re: Integrate Discoverer 11g with OAM 11g
          Michael Armstrong-Smith

          Hello

          You're not passing a port on the call. Was that intentional?

           

          Michael

          • 2. Re: Integrate Discoverer 11g with OAM 11g
            951803

            Hi,

             

             

            Created another SSO Agent with port number i.e base url of http://discod.mycomapny.com:80 but still the same error. Here discod.mycomapny.com is an alias that forwards all requests to OHS running at http://discovererdev01:8888. SSO Agent with direct hostname where OHS is running works fine but not when we introduce Alias.

             

            Thanks

            • 3. Re: Integrate Discoverer 11g with OAM 11g
              Michael Armstrong-Smith

              Hi

              So what's the full URL you are using? Remember that the URL needs to resolve to something on your network.

               

              Normally an invalid URL would result in something like these:

               

              • This page can't be displayed if using IE
              • Oops! Google Chrome could not find URL if using Chrome
              • Server not found if using Firefox.

               

              Mine does this even when I just make up a URL so what exactly is the error message you are seeing?

               

              You've not given us the actual URL you are using and I understand you don't want to publish your company's URL but if I take http://discod.mycomapny.com:80 and paste that into my browser I get one of the errors listed above. Can you double check you haven't got a typo in the URL itself with perhaps a space or control character where there shouldn't be one?

               

              If this is OK then I'm assuming that the URL is OK so now there may be something wrong inside your mod_osso file.

               

              Michael

              • 4. Re: Integrate Discoverer 11g with OAM 11g
                951803

                OHS is installed and running on where discovererdev01.mycompany.com is the actual machine hostname

                 

                http://discovererdev01.mycompany.com:8888

                 

                We have OAM SSO Agent that works fine using the above URL and when hitting  http://discovererdev01:8888/discoverer/plus we are directly logged-in

                 

                the users access disco using http://discovererdev01:8888/discoverer/plus which is an issue when we do DR so we created a new VIP and are using a Global Load balancer to forward all the requests from http://discod.mycomapny.com to our OHS. This way we don't have to hit discoverer using actual hostname and rather use the ALIAS discod.mycomapny.com this when in DR only change happens at Global Load Balancer.

                 

                So we updated the all the URL's in OAM SSO Agent from http://discovererdev01:8888 to http://discod.mycomapny.com and copied over the new osso.conf on to OHS server and restarted both OHS and OAM. But when hitting  http://discod.mycomapny.com/discoverer/plus get the error in the browser

                 

                System error. Please re-try your action. If you continue to get this error, please contact the Administrator.

                 

                 

                Even the same error in FireFox as in FireFox it should pop-up for OAM login screen but no so looks like it does hit OAM when using VIP. It only works when we use the actual machine hostname.

                 

                Below is what we have in mod_wl_ohs.conf file of OHS

                 

                <IfModule weblogic_module>

                WebLogicCluster discovererdev01.mycompany.com:7003

                DynamicServerList Off

                 

                        NameVirtualHost *:8888

                      

                        <VirtualHost *:8888>

                                ServerName discovererdev01.mycompany.com

                                ServerAlias discod.mycomapny.com

                                RewriteEngine ON

                                RewriteOptions inherit

                #                RewriteRule ^/$ http://discoa/discoverer/plus [R]

                 

                                <Location /discoverer>

                                        SetHandler weblogic-handler

                                        WebLogicCluster discovererdev01.mycompany.com:9008

                                </Location>

                 

                                <IfModule ossl_module>

                                        SSLEngine off

                                </IfModule>

                        </VirtualHost>

                </IfModule>

                 

                 

                We even created a new SSO Agent but still no luck. So wondering how does it work when using VIP instead of actual machine hostnames. Or is there anything I am missing. Anyone did that will appreciate any input to resolve this issue.

                 

                 

                Thanks