1 Reply Latest reply on Apr 14, 2014 8:15 PM by G Vijay

    "Java -version" command displays older version of Java in Command prompt

    G Vijay

      Hi All,


      I need to install one of the oracle Product for which i need to have the Java SE 6u43 version. i downloaded the required version form the oracle.com site and install it on my local machine. But when I run the java -version command on command prompt then this displays the Older version of java as below.


      Microsoft Windows [Version 6.1.7601]

      Copyright (c) 2009 Microsoft Corporation.  All rights reserved.


      C:\>java -version

      java version "1.4.2_03"

      Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_03-b02)

      Java HotSpot(TM) Client VM (build 1.4.2_03-b02, mixed mode)



      Currently in the My machine i can see following java version products.

      1. Java(TM) 6 Update 16

      2. Java(TM) 6 Update 43 (64-bit)

      3. Java(TM) SE Development kit 6 Update 43(64-bit)


      I tried to keep only one version of Java by removing the Java(TM) 6 Update 16 but still it displays the same version of java.


      Due to which i'm unable to install the another oracle product. Please let me know how i can update the java version and remove the old one.