3 Replies Latest reply on Apr 16, 2014 4:10 PM by alwu-Oracle

    Create_entailment fails with ORA-00933


      Hello everyone,

      when I try to launch the creation of a new entailment,


      EXECUTE sem_apis.create_entailment('my_entailment', sem_models('my_model'), sem_rulebases('owlprime'));


      the procedure fails with the following error:


      ORA-00933: comando SQL terminato erroneamente
      ORA-06512: a "MDSYS.SDO_SEM_INF_INTERNAL", line 13518
      ORA-06512: a "MDSYS.SDO_SEM_INFERENCE", line 142
      ORA-06512: a "MDSYS.SDO_SEM_INFERENCE", line 184
      ORA-06512: a "MDSYS.RDF_APIS", line 108
      ORA-06512: a line 1
      00933. 00000 -  "SQL command not properly ended"


      I've never experienced this problem when I was working on my instance of my Windows Server 2008 R2 machine, but it's happening now that I've migrated to The very same command that used to work is not working anymore; this happens on the migrated database as well as on a brand new database. Also, I've checked MDSYS.RDF_PARAMETER and SEM_VERSION 11203 is valid.


      I've done some research, but I haven't found anything on this matter.. and the error message is not helping me in trying to understand what's going wrong.


      Any suggestion?

        • 1. Re: Create_entailment fails with ORA-00933



          Is there any changes for character set, nls setting, etc. with the new database?

          Before you run the create entailment command, does it help to run the following first?





          Zhe Wu

          • 2. Re: Create_entailment fails with ORA-00933

            Dear Zhe,


            this solved the problem!


            The previous value for NLS_NUMERIC_CHARACTERS was ',.' . However, it still bothers me why this happened: to answer your question, yes, the new database was created with Italian NLS settings, but I don't see how that could have had an impact on the older database.. Also, I understand how this parameter could have generated the error I reported, but how could I have understood that that's where I had to look?


            Thank you so much for your help,



            • 3. Re: Create_entailment fails with ORA-00933

              Hi Enrico,


              Glad it worked for you. Well, when an error like this happened, if you really want to figure out what's going on by yourself, you can turn on some extensive tracing at the SQL level. An alternative is to post a question on this Forum (like you did) or send a SR to Support.




              Zhe Wu