3 Replies Latest reply: May 8, 2014 7:51 AM by ElMasry RSS

    11204 Installation Trouble on RHEL 6.4

    sprashant

      Hi

      I am facing trouble on installing RAC cluster software on RHEL 6.4 Platform.

       

      First i finished the CRS installation of 11204 on two node RAC Cluster running on RHEL 6.4 and verified all cluster properties.

      Cluster looks healthy and all cluvfy checks are passing fine.

       

      When i invoke the runinstaller for Cluster database installation, it is not recognizing cluster and not moving ahead.

      Exact Error is

       

      [INS-35423]The installer has detected that Oracle Clusterware is not running on the local Node.

       

      I am running the runinstaller as oracle user and it can see the cluster fine.

       

      $ crsctl check crs

      CRS-4638: Oracle High Availability Services is online

      CRS-4537: Cluster Ready Services is online

      CRS-4529: Cluster Synchronization Services is online

      CRS-4533: Event Manager is online

       

      Need Help to bypass error and move ahead

       

      Thanks

      Prashant

      ORACLE DBA

        • 1. Re: 11204 Installation Trouble on RHEL 6.4
          Shilpi-Oracle

          Hi Prashant,

           

           

          Regarding error,

          [INS-35423] The installer has detected that Oracle Clusterware is not running on local node.

           

           

          CAUSE: You have chosen to install Oracle RAC when Oracle Clusterware stack is not running on the local node.

           

           

            ACTION: Start the Oracle Clusterware stack by running the following command as the root user from the Oracle Clusterware home (Grid home) : /bin/crsctl start crs. When the Oracle

          Clusterware stack is running, restart the installer and continue with the Oracle RAC installation.

           

           

          Please refer document "[INS-35423] The installer has detected that Oracle Clusterware is not running on local node. (Doc ID 1533356.1)" on My Oracle Support for details.

           

           

          Thanks,

           

          Shilpi

          • 2. Re: 11204 Installation Trouble on RHEL 6.4
            sprashant

            Thanks for response shilpi

            It was not about /etc/hosts as mentioned in the Metalink Note

            I opened SR on this issue and solution provided by Oracle Support worked for me.

            Below is the details for everyone's reference

             

            ==============================================

            Hello Prashant,

            Thanks for the update.
            --------------
            <HOME_LIST>
            <HOME NAME="Ora11g_gridinfrahome1" LOC="/etrade/pkgs/linux/intel/oragrid/11.2.0.4.grid.x86_64" TYPE="O" IDX="1"> <<<<<<<<<< CRS=TRUE is missing.
              <NODE_LIST>
              <NODE NAME="opocdb41w153m3"/>
              <NODE NAME="opocdb42w153m3"/>
              </NODE_LIST>
            --------------

            The Central Inventory.xml shows the "CRS=ture" flag is unset. Pls set this by using the following

            On Node-1 run this as GI_HOME user :
            $/etrade/pkgs/linux/intel/oragrid/11.2.0.4.grid.x86_64/oui/bin/runInstaller -updateNodeList ORACLE_HOME="/etrade/pkgs/linux/intel/oragrid/11.2.0.4.grid.x86_64" CRS=true

            After successfully updating the Central inventory you can see the following line as follows..

            <HOME NAME="Ora11g_gridinfrahome1" LOC="/etrade/pkgs/linux/intel/oragrid/11.2.0.4.grid.x86_64" TYPE="O" IDX="1" CRS="true"> 

             

            ==============================================

            • 3. Re: 11204 Installation Trouble on RHEL 6.4
              ElMasry

              Thanks , worked with me