5 Replies Latest reply: May 13, 2014 7:24 AM by Jayaprakash -Oracle RSS

    500 Internal Server Error after enabling ssoMode=true

    user560883

      Hi Experts

       

      Environment

      Oracle Application Server 10.1.2.3.0      (Infrastructure & Midtier) Single Machine

      OS MS Windows Server 2003 EE SP2

       

      Issue:

      While trying to configure SSO to allow users to call reports from Forms without getting login prompt, we are getting the following error.

       

      java.lang.NullPointerException

      at javax.naming.InitialContext.getURLScheme(InitialContext.java:224)

      at javax.naming.InitialContext.getURLOrDefaultInitCtx(InitialContext.java:273)

      at javax.naming.directory.InitialDirContext.getURLOrDefaultInitDirCtx(InitialDirContext.java:85)

      at javax.naming.directory.InitialDirContext.search(InitialDirContext.java:238)

      at oracle.ldap.util.User.locateSubscriber(User.java:1122)

      at oracle.ldap.util.User.getExtendedProperties(User.java:324)

      at oracle.forms.servlet.FormsOIDContext.getUserCredentials(Unknown Source)

      at oracle.forms.servlet.FormsServlet.getUserId(Unknown Source)

      at oracle.forms.servlet.FormsServlet.doRequest(Unknown Source)

      at oracle.forms.servlet.FormsServlet.doGet(Unknown Source)

      at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)

      at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)

      at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.ServletRequestDispatcher.invoke(ServletRequestDispatcher.java:835)

      at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.ServletRequestDispatcher.forwardInternal(ServletRequestDispatcher.java:341)

      at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:816)

      at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.AJPRequestHandler.run(AJPRequestHandler.java:231)

      at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].server.http.AJPRequestHandler.run(AJPRequestHandler.java:136)

      at com.evermind[Oracle Application Server Containers for J2EE 10g (10.1.2.3.0)].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:192)

      at java.lang.Thread.run(Thread.java:534)

       

      When ssoMode is set to false, it works fine. with ssoMode=true, it shows the login page for OID and once user credentials are entered it throws the above error.

      Verified that mod_osso is working fine by following note 302721.1

      Checked note 1086817.1 to try and troubleshoot but it did not help.

      Already verified that OID entry and formsweb.cfg entry match for oid_formsid and formsid_group_dn.

       

      Any help will be greatly appreciated.

      Thank you