2 Replies Latest reply: May 14, 2014 1:47 AM by Tom321 RSS

    Cannot Open Database Installer Display in Solaris 11 zone




      I know this sound like a repost but I think this time it's different. I already checked all this threads and links:


      Oracle 11g R2 installation on Solaris 11

      Could not execute auto check for display colors using command /usr/openwin/

      Edge: Installation of Oracle 11g Release 2 on Solaris 10 x86_64


      HOWTO: Get xterm on Solaris 11 Without installing the Whole of the solaris-desktop Group · Col's Tech


      In resume I already installed every package I should install for the X server to work, my DISPLAY variable is set, yet the installer still hangs saying I don't have it.


      root@oracle-beta:~# pkginfo

      system      SUNWarc                  Lint Libraries (usr)

      system      SUNWbtool                CCS tools bundled with SunOS

      system      SUNWfont-xorg-core       X.Org Foundation X11 core fonts

      system      SUNWfont-xorg-iso8859-1  X.Org Foundation X11 iso8859-1 fonts

      system      SUNWhea                  SunOS Header Files

      system      SUNWlibm                 Math & Microtasking Library Headers & Lint Files (Usr)

      system      SUNWlibms                Math & Microtasking Libraries (Usr)

      system      SUNWmfrun                Motif RunTime Kit

      system      SUNWpool                 Resource Pools

      system      SUNWpoolr                Resource Pools (Root)

      system      SUNWsprot                Solaris Bundled tools

      system      SUNWtoo                  Programming Tools

      system      SUNWuiu8                 Iconv modules for UTF-8 Locale

      system      SUNWxorg-client-programs X.Org Foundation X Client Programs

      system      SUNWxorg-clientlibs      X.Org Foundation X Client Libraries

      system      SUNWxorg-compatlinks     X11 Compatibility Links

      system      SUNWxorg-headers         Xorg server SDK headers

      system      SUNWxorg-mesa            Xorg Server Mesa Modules and Libraries

      system      SUNWxorg-server          X.Org Foundation Xserver

      system      SUNWxorg-xkb             X.Org Foundation Xserver keyboard layouts

      system      SUNWxwdem                X Window System demo programs

      system      SUNWxwfsw                X Window System platform required font software

      system      SUNWxwice                X Window System Inter-Client Exchange (ICE) Components

      system      SUNWxwplt                X Window System platform software


      Here is the error output, the error only comes out when I cancel the operation, I literally left to lunch and came back and the window wasn't up:


      Checking Temp space: must be greater than 180 MB.   Actual 47754 MB    Passed

      Checking swap space: must be greater than 150 MB.   Actual 56975 MB    Passed

      Checking monitor: must be configured to display at least 256 colors^C


      >>> Could not execute auto check for display colors using command /usr/openwin/bin/xdpyinfo. Check if the DISPLAY variable is set.    Failed <<<<


      Some requirement checks failed. You must fulfill these requirements before continuing with the installation,


      I also tried using xeyes or running xhost +, to see if anything works but everything hangs forever. Also, I tried connecting remotely using XShell and SecureCRT, with Xmanager running passive from a Windows machine. I don't know why I can't see the remote windows, or remote installers.


      Please help. Even If you know how to install it in a non graphical way it would help.



        • 1. Re: Cannot Open Database Installer Display in Solaris 11 zone
          Srini Chavali-Oracle

          Silent installs are documented - Installing and Configuring Oracle Database Using Response Files


          What is the output of command "echo $DISPLAY" just before the installer is invoked ? What server does the IP address or server name refer to ?



          • 2. Re: Cannot Open Database Installer Display in Solaris 11 zone

            Hi Nock,


            i install these packages on solaris zones


            Large Server as default zone is very slim and misses many tools and commands. xclock for display testing, ucb is required for patching later, third line are all packages recommended and available in Solaris 11

            root@TCE-Entw:~# pkg install group/system/solaris-large-server

            root@TCE-Entw:~# pkg install xclock libxmuu x11-info-clients compatibility/ucb

            root@TCE-Entw:~# pkg install SUNWarc SUNWbtool SUNWhea SUNWlibC SUNWlibm SUNWlibms SUNWsprot SUNWtoo SUNWcsl SUNWxcu4 pkg://solaris/SUNWxwplt


            this is my grid user profile:






            AWT_TOOLKIT=XToolkit        <<<<<<<<<<<<<<<<<< set  and export this parameter for display output







            ulimit –t unlimited

            ulimit –f unlimited

            ulimit –d unlimited

            ulimit –s unlimited

            ulimit –v unlimited