2 Replies Latest reply: May 15, 2014 3:14 PM by BPeaslandDBA RSS

    vip od 2nd node is missing !

    shipon_97

      Dear Friends ,

       

      I am going to configure a new Oracle 11g RAC  on Virtual Machine with Oracle Ent Linux 5.4 . I have to completed grid configuration successfully .

      Then When I am going to install database it shows the error :

      "

      PRVF-4556:  Failed to check existence of node

       

      Then I check the nodes and found that in Node2, vip is not configured . Then I perform the below tasks :

       

      > Add a VIP :  /u01/app/11.2.0/grid/bin/srvctl add vip -n ol5-112-rac2  -A 192.168.50.104/255.255.255.0 -k 2

       

      > Make it Start :

       

      [root@ol5-112-rac2 ~]# /u01/app/11.2.0/grid/bin/srvctl start  vip -i ol5-112-rac2-vip -v

      Successfully started VIP.

       

      > Check status :

       

      [root@ol5-112-rac2 ~]# /u01/app/11.2.0/grid/bin/srvctl status  vip -n ol5-112-rac2

      VIP 192.168.50.104 is enabled

       

      But my problem still not resolved . I have to check the output and found no entry of VIP (NODE2) :

       

      >>

      [root@ol5-112-rac2 ~]# /u01/app/11.2.0/grid/bin/srvctl status nodeapps

      VIP ol5-112-rac1-vip is enabled

      VIP ol5-112-rac1-vip is running on node: ol5-112-rac1

      Network is enabled

      Network is running on node: ol5-112-rac1

      Network is running on node: ol5-112-rac2

      GSD is disabled

      GSD is not running on node: ol5-112-rac1

      GSD is not running on node: ol5-112-rac2

      ONS is enabled

      ONS daemon is running on node: ol5-112-rac1

      ONS daemon is running on node: ol5-112-rac2

      eONS is enabled

      eONS daemon is running on node: ol5-112-rac1

      eONS daemon is running on node: ol5-112-rac2

       

       

       

      >>

       

      [root@ol5-112-rac2 ~]# /u01/app/11.2.0/grid/bin/olsnodes -i

      ol5-112-rac1    ol5-112-rac1-vip

      ol5-112-rac2    <none>

       

       

      Would anybody please provide a solution , how can I add vip in 2nd node so that I found my "vip of 2nd node" available using the above two queries .

        • 1. Re: vip od 2nd node is missing !
          J.A.

          When you install the Grid Software, did you find any problem ?, because you have to choose there the VIP for each node.

          Did you register the VIP on both nodes or are you using a DNS ?

          Is this a Production environment or is it for testing purpose ?

           

          If you are installing with GUI then you don't have to start anything manually.

           

          Run this and post result:

          ./crsctl query css votedisk

           

          ./cluvfy stage -post nodeadd -n all -verbose

           

           

          Regards

          • 2. Re: vip od 2nd node is missing !
            BPeaslandDBA

            Not sure why you are trying to add a VIP here. If you installed Grid Infrastructure correctly, then the VIP's should have been added at that time. There is a screen in the GI OUI that specifically asks for your VIP names for each node. Also, the PRVF-4556 error is not giving you any indication that the VIP is down. This error is saying that the other nodes in the cluster cannot be found. In other words, that the cluster itself isn't functioning correctly. I would run the cluster verification utility (cluvfy) as follows:

             

            cd $GRID_HOME/bin

            ./cluvfy stage -post crsinst -n host01,host02

             

            If you have more than two hosts, add them to the list. Post the output so that we can take a look at it.

             

            Thanks,

            Brian