4 Replies Latest reply: Jun 2, 2014 3:58 AM by 1147721 RSS

    The file path +DATA/orcl/system01.dbf is invalid. Please check the permissions.

    535871

      Hi,

       

      I am unable to create database through dbca on linux. I am getting below error,

       

      The file path +DATA/orcl/system01.dbf is invalid. Please check the permissions.

       

      Please help...

       

      Thanks,

        • 1. Re: The file path +DATA/orcl/system01.dbf is invalid. Please check the permissions.
          Hemant K Chitale

          Did you manually specify the full path ?  +DATA is expected to be an ASM Disk Group.  What version are you running ?  (e.g. if 11gR2, ASM would be running from a separate Grid Infrastructure install and the RDBMS install needs to be able to connect to the ASM instance running from the G.I. install)

           

           

          Hemant K Chitale


          • 2. Re: The file path +DATA/orcl/system01.dbf is invalid. Please check the permissions.
            535871

            Yes i specify path manually for +DATA and +FRA (ASM Disk Groups). The version is 11gR2. ASM Disk Group were created from grid user i am creating database from Oracle user. Both Grid and Database have different installation homes.

            • 4. Re: The file path +DATA/orcl/system01.dbf is invalid. Please check the permissions.
              1147721

              Hello,

               

              first of all, I would try to make sure the name of the diskgroup is the one you have specified. As grid user, find the asm instance name and export the environment variables :

               

              $ ps -ef|grep pmon

              $ export ORACLE_SID=<ASM_INSTANCE_NAME>

              $ export ORACLE_HOME=<ORACLE_GRID_HOME>

               

              Then query the existing diskgroups in ASM :

               

              $ asmcmd

              ASMCMD> lsdg

               

              That will give you the names of the diskgroups in the last column.

               

              Then you can try to write to that diskgroup with the oracle user. You could try to create the spfile for the database in the diskgroup, for example :

               

              SQL> show parameter spfile

               

              NAME                     TYPE     VALUE

              ------------------------------------ ----------- ------------------------------

              spfile                     string     /oracle/app/product/11.2.0.4/d

                                       b1/dbs/spfiledb2.ora

              SQL> create pfile='/tmp/pfiletest.ora' from spfile;

               

              File created.

               

              SQL> create spfile='+ASMDG' from pfile='/tmp/pfiletest.ora';

               

              File created.

               

              SQL>

               

              If the file is created ok, you can check it in asmcmd as grid user :

               

              $ asmcmd

              ASMCMD> pwd

              +asmdg/db_unknown/parameterfile

              ASMCMD> ls -ls

              Type           Redund  Striped  Time             Sys  Block_Size  Blocks  Bytes    Space  Name

              PARAMETERFILE  UNPROT  COARSE   JUN 02 10:00:00  Y           512       5   2560  1048576  SPFILE.256.849177899

              ASMCMD>

               

              If all this works ok, you should be able to create the datafiles, just specifiying the name of the diskgroup, not the full path, so when running dbca, in the step for the Database File Locations, just choose ASM and if you press the "Browse..." button for "Use Oracle-Managed Files", a list for the diskgroups will appear. Just choose the one you want and you're done.

               

              I hope that helps.

               

              regards.