4 Replies Latest reply on Jun 24, 2014 1:36 PM by Scott_Symonds

    Forms reports 11g weblogic  installation and configuration issue




      I got an error 'Create Domain failed' while trying to configure forms and reports +  weblogic  in Windows 8 (64) env.


      Please find the steps which I have followed ..

      Installed JDK 1.6 

      Installed Oracle Forms and Reports 11g Release 2 (

      Installed Oracle WebLogic Server 11gR1 (10.3.5)

      I tried configuring weblogic for forms 11g  using 'Configure Classic Instance'. After navigating through different steps,

      I click on 'Configure' button, but the ' Create Domain' seems failed.


      I tried different ways like removing space from PATH variables, stopping the node manager, modify host file. But issue still exists.

      I saw a warning initially during installation which showed about Certificate, but I ignored and continued.

      Below are the last few lines of log.



      [2014-06-23T17:21:08.283+03:00] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000KR96RTzAdL0pNws1ye1Je3UG000004,0] Oracle Home: C:/Oracle/Middleware/Oracle_FRHome1

      [2014-06-23T17:21:08.283+03:00] [as] [NOTIFICATION] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000KR96RTzAdL0pNws1ye1Je3UG000004,0] Setting os object values in Python

      [2014-06-23T17:21:17.493+03:00] [as] [ERROR] [] [oracle.as.provisioning] [tid: 13] [ecid: 0000KR96RTzAdL0pNws1ye1Je3UG000004,0] [[

      oracle.as.provisioning.exception.ASProvWorkflowException: Error Executing workflow.

      at oracle.as.provisioning.engine.WorkFlowExecutor._createDomain(WorkFlowExecutor.java:686)

      at oracle.as.provisioning.engine.WorkFlowExecutor.executeWLSWorkFlow(WorkFlowExecutor.java:391)

      at oracle.as.provisioning.engine.Config.executeConfigWorkflow_WLS(Config.java:866)

      at oracle.as.install.classic.ca.standard.StandardWorkFlowExecutor.execute(StandardWorkFlowExecutor.java:65)

      at oracle.as.install.classic.ca.standard.AbstractProvisioningTask.execute(AbstractProvisioningTask.java:26)

      at oracle.as.install.classic.ca.standard.StandardProvisionTaskList.execute(StandardProvisionTaskList.java:61)

      at oracle.as.install.classic.ca.ClassicConfigMain.doExecute(ClassicConfigMain.java:124)

      at oracle.as.install.engine.modules.configuration.client.ConfigAction.execute(ConfigAction.java:375)

      at oracle.as.install.engine.modules.configuration.action.TaskPerformer.run(TaskPerformer.java:88)

      at oracle.as.install.engine.modules.configuration.action.TaskPerformer.startConfigAction(TaskPerformer.java:105)

      at oracle.as.install.engine.modules.configuration.action.ActionRequest.perform(ActionRequest.java:15)

      at oracle.as.install.engine.modules.configuration.action.RequestQueue.perform(RequestQueue.java:96)

      at oracle.as.install.engine.modules.configuration.standard.StandardConfigActionManager.start(StandardConfigActionManager.java:186)

      at oracle.as.install.engine.modules.configuration.boot.ConfigurationExtension.kickstart(ConfigurationExtension.java:81)

      at oracle.as.install.engine.modules.configuration.ConfigurationModule.run(ConfigurationModule.java:86)

      at java.lang.Thread.run(Thread.java:662)


      Can someone help me to resolve this issue?

        • 1. Re: Forms reports 11g weblogic  installation and configuration issue

          Oracle Forms is not supported with Oracle WebLogic Server 10.3.5. It is only certified with Oracle WebLogic Server version 10.3.6 according to the Oracle Forms 11gR2 certification matrix: Oracle Fusion Middleware Supported System Configurations


          NOTE: Installing WebLogic 10.3.6 will require installing a new Middleware home, so it is recommended to deinstall the current Forms installation you are attempting to install first. After that, you may install a new Middleware home for Forms using WebLogic 10.3.6. You may also use the same JDK assuming it is version 1.6.0_35 or higher.


          Good luck!



          • 2. Re: Forms reports 11g weblogic  installation and configuration issue

            There is an order to the installation.  Uninstall Fusion Middlware (FMw) 11g R2 and WebLogic Server (WLS) 10.3.5.  Then reinstall - installing WLS first (do not run the configuration step at the end of the installation).  Once complete, install FMw and run the configuration step during installation (step 14 or 15 if I remember right).


            Also, what version/update of Java 1.6.0 did you install?  FMw's default configuration is to use Java 1.6.0_12, but it is recommend you install the latest update (1.6.0_45).  In addition to everthing else, I don't believe FMw has been approved/certified for installation on Windows 8 yet.



            • 3. Re: Forms reports 11g weblogic  installation and configuration issue

              Hi Crag/Scott,


              Thanks for the guidance. I tried the way you have explained, but the issue remains. I Uninstalled FMw 11g R2 and WLS 10.3.5.  Installed another version, WLS 10.3.6 (as recommended by scott). Installed FMw with configuration.

              Initially I had JDK 1.6.0_30-b12. Today, tried even with JDK 1.8.0_05-13. I was trying to do this installations at C:\,

              created a master folder Oracle and sub-folders, Java and Middleware. I had already installed Oracle 11g db in the same C:\.


              Could be this be a certificate issue with windows 8 ?. But I could find few posts where people claims to have this

              setup installed.


              Below is Path :



              2.0\dbhome_1\bin;C:\PROGRA~2\Intel\iCLS Client\;C:\PROGRA~1\Intel\iCLS Client\;C


              wsPowerShell\v1.0\;C:\PROGRA~1\ThinkPad\Bluetooth Software\;C:\PROGRA~1\ThinkPad

              \Bluetooth Software\syswow64;;C:\PROGRA~1\Intel\Intel(R) Management Engine Compo

              nents\DAL;C:\PROGRA~1\Intel\Intel(R) Management Engine Components\IPT;C:\PROGRA~

              2\Intel\Intel(R) Management Engine Components\DAL;C:\PROGRA~2\Intel\Intel(R) Man

              agement Engine Components\IPT;C:\ProgramData\Lenovo\ReadyApps;C:\PROGRA~1\Intel\

              WiFi\bin\;C:\PROGRA~1\Common Files\Intel\WirelessCommon\;C:\Oracle\Java


              Any other thoughts, plz ??



              • 4. Re: Forms reports 11g weblogic  installation and configuration issue

                According to the support matrix link I provided in my previous post, Windows 8 is currently not certified with any version of Oracle Forms right now. That is likely a reason why you are experiencing the error when configuring Forms. I can provide a couple other tips which you can try, but Oracle will not be able to support you with configuring Forms 11gR2 in Windows 8:


                1. Make sure you are using a static IP address. If you do not use a static IP address, you will need to install a loopback adapter from Microsoft, configure a static IP address with it, and add the IP address and your hostname to the hosts file.

                2. Make sure you have full administrative rights. This means you are able to run anything as an administrator.

                3. In your PATH, I see "Intel(R)". Having parentheses in the PATH has also been known to cause issues when configuring Forms.


                I would retry the Forms configuration by following these steps (this will follow tips 2 and 3):

                1. Run Command Prompt as an administrator (Right-click on cmd.exe and select "Run as administrator".)

                2. Navigate to C:\Oracle\Middleware\Oracle_FRHome1\BIN

                3. Set your PATH as follows: set PATH=C:\Oracle\Middleware\Oracle_FRHome1\BIN;C:\windows\system32;C:\windows;C:\windows\System32\Wbem;C:\windows\System32\WindowsPowerShell\v1.0

                4. Run: config.bat


                Again, as you are installing in an unsupported OS platform, the configuration may or may not work, but the above tips are what I recommend when installing in a supported platform such as Windows 7.