3 Replies Latest reply: Jun 27, 2014 9:54 AM by Michael Peel-Oracle RSS

    initialize_services failing

    1896227

      [06.19.14 11:06:54] INFO: Updating IAP Workbench configuration...

      [06.19.14 11:06:54] INFO: Downloading config files from Web Studio.

      [06.19.14 11:06:54] INFO: [ITLHost] Starting shell utility 'cleanDir_config'.

      [06.19.14 11:06:54] SEVERE: Utility 'cleanDir_config' failed. Refer to utility logs in [ENDECA_CONF]/logs/shell on host ITLHost.

      Occurred while executing line 5 of valid BeanShell script:

      [[

       

      2|

      3|    if (ConfigManager.isWebStudioEnabled()) {

      4|      log.info("Updating IAP Workbench configuration...");

      5| ConfigManager.updateWsConfig();

      6|      log.info("Finished updating IAP Workbench.");

      7|    }

      8|

       

      ]]

       

      [06.19.14 11:06:54] SEVERE: Caught an exception while invoking method 'run' on object 'InitialSetup'. Releasing locks.

       

      Caused by java.lang.reflect.InvocationTargetException sun.reflect.NativeMethodAccessorImpl invoke0 - null

      Caused by com.endeca.soleng.eac.toolkit.exception.AppControlException com.endeca.soleng.eac.toolkit.script.Script runBeanShellScript - Error executing valid BeanShell script.

      Caused by com.endeca.soleng.eac.toolkit.exception.EacComponentControlException com.endeca.soleng.eac.toolkit.utility.Utility run - Utility 'cleanDir_config' failed. Refer to utility logs in [ENDECA_CONF]/logs/shell on host ITLHost.

       

      Failed to setup EAC application.

       

      ------------------

      there is no info on the log files in [ENDECA_CONF]/logs/shell

       

      Any ideas?

        • 1. Re: initialize_services failing
          Michael Peel-Oracle

          Usually means you are running on Windows and there is a file system lock on .\data\web_studio\config directory, possibly due to having an Explorer window open to the .\data\ directory, or anti-virus scanning.  Try manually deleting and recreating the .\data\web_studio\config directory.

           

          Thanks

           

          Michael

          • 2. Re: initialize_services failing
            1896227

            Hi Michael,

             

            dont think this is the case in this instance. If I try to manually run the emgr_update command the command is not recognised even though the ENDECA_ROOT variable is set correctly and the path variable contains %ENDECA_ROOT%\bin

             

            The machine is rebooted every night but this morning I tried the emgr_update command with the explicit file path prefixing emgr_update and it worked. So I updated the path variable to explicitly include the file path, rebooted and it worked. Unfortunately when I remove the explicit path and reboot it still works so I'm non the wiser about how this problem has been fixed.

             

            The bottom line is that it is fixed now and I have several things to try if it happens again.

             

            Thanks

            • 3. Re: initialize_services failing
              Michael Peel-Oracle

              Weird, the SEVERE: Utility 'cleanDir_config' failed error doesn't do anything at all with emgr_update, that comes afterwards (the cleanDir_config cleans out the directory that emgr_update downlaods the Workbench files to).  Still, as long as it is working now!