2 Replies Latest reply on Jul 4, 2014 4:14 PM by Cindys-Oracle

    raidz2 failure


      I have a raidz2 with 8x3tb wd red drives.

      The automatic email sending I set up in napp-it doesn't seem to work so I missed that I had a problem with a sata power splitter. Two disks dropped(2 & 3) and was discovered off and on during a period of about two weeks.

      I didn't notice this but last night another disk(7) in the raid reported errors and the pool got the status UNAVAIL. I shut the computer down, replaced the faulty power splitter and power it back up.

      The status of the pool is still UNAVAIL, the two disks(2 & 3) that had problem with the power splitter one say DEGRADED and one UNAVAIL, the last disk(7) that broke is also UNAVAIL.

      Thinking all is lost(18tb data and no backup, yeah I know) I tried clearing the errors of the last disk(7) and when I got the prompt back I ran a status on the pool.

      Disk 7 is now ONLINE and 2&3 is resilvering. I left it and came back an hour later to check on the progress. The resilvering is still going but disk 7 is now also resilvering.


      How can three disks in a raidz2 resilver at the same time?

      Am i screwed or what? I guess I'll find out 91h from now.


      Current status:

        pool: ARC

      state: DEGRADED

      status: One or more devices is currently being resilvered.  The pool will

              continue to function in a degraded state.

      action: Wait for the resilver to complete.

              Run 'zpool status -v' to see device specific details.

        scan: resilver in progress since Fri Jul  4 12:06:17 2014

          465G scanned out of 20.0T at 62.1M/s, 91h41m to go

          60.2G resilvered, 2.27% done




              NAME         STATE     READ WRITE CKSUM

              ARC          DEGRADED     0     0     0

                raidz2-0   DEGRADED     0     0     0

                  c10t0d0  ONLINE       0     0     0

                  c10t1d0  ONLINE       0     0     0

                  c10t2d0  DEGRADED     0     0     0  (resilvering)

                  c10t3d0  DEGRADED     0     0     0  (resilvering)

                  c10t4d0  ONLINE       0     0     0

                  c10t5d0  ONLINE       0     0     0

                  c10t6d0  ONLINE       0     0     0

                  c10t7d0  DEGRADED     0     0    21  (resilvering)



      errors: No known data errors

        • 1. Re: raidz2 failure

          Resilver stoped and all devices in raid show as degraded as well as the pool itself, this after 155gb resilvered.

          I guess I can expect these 18tb gone then.

          • 2. Re: raidz2 failure

            If you have resolved the power issues or have identified what other other larger problem might be causing all devices to go UNAVAIL, then your change of recovery are better. A RAIDZ2 config can only withstand the failure of 2 disks but if your devices are only DEGRADED, you might be able to recover your data. Have you tried to copy the data from this pool?


            Thanks, Cindy